Need some help with my Remington 7600


PDA






jdk829
January 4, 2011, 06:05 PM
I bought a Remington 7600 caribine in .308 a few years ago on a whim, because I wanted a pump action rifle. I finally took it out of the box and out to shoot. It will not strip cartridges from the magazine when you work the action. I've tried several magazines, but no luck. Unlike the 7615's, the magazine is a little tricky to get seated. However, I confirmed it's inserted correctly. I'm still not convinced, though, the problem is with the rifle and not the magazines. Can anyone offer any help or suggestions? I thought I read before that sometimes the "lip" of the magazine on these rifles need to be manipulated/bent for them to feed properly, but I could be wrong. Thanks.

If you enjoyed reading about "Need some help with my Remington 7600" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
thunder173
January 4, 2011, 06:28 PM
Hmmm,...I don't have a 7600,..but I do have a 760 and a 7615. Something doesn't seem right for certain. Both my pumps are as reliable as can be,....

If your mag is fully seated, but still not picking up the next round when racked,....is your bolt going fully to the rear when you rack it?? If not,..then it wouldn't be able to pick up the next round in the mag,..as it would just continue to ride over it.....

If it were me,..I'd check there,...see if something is restricting the bolt from going fully to the rear. There are a couple guys on here that may weigh in,..RCModel, and Krochus,...you might want to look them up,..and maybe send them a PM,...they'd likley be the guys to get you going in the right direction.

Good luck,...Hope you enjoy that 7600 when ya get it running right.

243winxb
January 4, 2011, 06:34 PM
The head of the cartridge must ride high enough in the magazine for the bolt to make contact on closing and pick up the round. As said above > see if something is restricting the bolt from going fully to the rear.

jdk829
January 4, 2011, 08:44 PM
thanks for the help. indeed, the bolt was not fully opening. the foregrip was not cut out enough on the bottom where it wraps around the magazine, thus not allowing the action to fully open, but letting you feel like it did when it bumped the magazine . the rifle is a "special run" from remington with a synthetic apg camo stock. a manufacting defect, i suppose. i'm just going to take it off and hit it with my dremel. cheers.

thunder173
January 4, 2011, 09:17 PM
Let us know how that works out. Suffice to say,.....Do be cautious if your are racking live ammo through the gun. Not an action I'd recommend. Dummy rounds would be ohso much bettah.......

If you enjoyed reading about "Need some help with my Remington 7600" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!