Problem installing IRAS system stem on Tech Sight MINI200 sight


PDA






Smiling Bob
February 5, 2011, 05:27 PM
I am having a problem installing IRAS stem on Tech Sight MINI200 sight. I just received my Tech Sight MINI200 sight and IRAS system today. Followed directions to remove the fixed aperture stem from the sight and had no problems. Having a hell of a time reinstaling the IRAS aperture stem. What's the trick to getting the stem reinstalled?

Smiling Bob :D

If you enjoyed reading about "Problem installing IRAS system stem on Tech Sight MINI200 sight" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
WNTFW
February 6, 2011, 02:13 PM
If I understand your problem, you have to push the tumbwheel in against a spring & detent ball to center up the threaded hole. IIRC there is pretty good force needed.

I will get one of my tech-sights & see if that is it.

Post back later.

Smiling Bob
February 6, 2011, 05:06 PM
WNTFW,

Finally got the IRAS aperture stem installed. Had to hold my mouth right as I simultaneously pushed the elevation dial in with one hand, while turning it with the other hand, and holding the aperture with my other hand. :rolleyes:
In reality I had my wife assist me with holding the aperture stem.

Smiling Bob :D

If you enjoyed reading about "Problem installing IRAS system stem on Tech Sight MINI200 sight" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!