Mosquito Problems


PDA






SIGLBER
February 13, 2011, 03:35 AM
O.K. so my Mosquito was great for th first 2000 rounds. Now I'm having problems with it. Failures to feed even with CCI MiniMags. SIG told me it was fine and said they won't work on it again. Here's what happens. It will fire and eject a round. Then will not pick up the next round from the magazine.
1. Clean and lube it after every shooting session'
2. Using the perscribed MiniMags.
3. Happens on two different magazines.
4. Slide is definately short stroking on the rounds it does not pick up. I can feel the difference in some of the rounds not cycling the slide fully. The only thing I can find wrong is that the "gut" of the pistol from the breechfach on back are so loose I can wiggle them back and forth. Anyone know how to tighten these down? Only thing I can find wrong. Doubt a bunch of weak loads from several boxes of the MiniMags. It used to shoot the Federal Auto Match excellently. Whatever is going it will now not cycle the Auto Match ammo. So it's a problem in the pistol not the ammo. Maybe time to sell it. Doubt I will get much in trade. Shame I really like the little pistol.

If you enjoyed reading about "Mosquito Problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
swmp9jrm
February 13, 2011, 09:55 AM
Have you checked the tightness of the barrel screw? There are some posts over on the SIG forum about Mosquito problems caused by this screw being a bit loose.

SIGLBER
February 13, 2011, 12:57 PM
Yeah the barrel is tight. Like I said the breechface on back is loose. I don't know what can be tightened on it. Mississippi Dav's writitngs don't seem to cover anything like this.

If you enjoyed reading about "Mosquito Problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!