Busted Lyman Turbo 600


PDA






ColtPythonElite
February 18, 2011, 07:20 PM
So, I have a Turbo 600 that I bought used 19 years ago. All this time, I have had the small bowl. A while back, I decided to upgrade to an Auto Flo bowl. It came in the mail today. The instructions were vague, but pretty much self-explanatory. Basically, you just remove the tumblers center stud, replace it with a longer one, and put the bowl on. Simple enough. I threaded the stud in a bit and slipped the new bowl on. There was about 3" of stud sticking out above the bowl lid. I figured I turn the stud down in further to make make it easier to get the nut off that holds the lid down. I double nutted the stud and turn it down a bit more. Put the bowl on and flipped on the power. I got no tumbling, just a hum. I ended up taking the entire thing apart. I found that the new stud had threaded down and kept on going. It pushed the guts of the motor right out of the housing and in the process broke the pot metal tabs that held the windings in. It was basically trashed.:cuss:....Oh, well time for a new tumbler. I found a Pro 1200 on sale at Cabela's for 48 bucks. I called up Walmart and found out they had them in stock for 66 bucks. I knew they advertised price matching. I drove over and asked the guy about price matching. He said they would until he saw I had printed out the sale from Cabelas. He said they only priced matched local stores...I told him no thanks. I can wait 3 days for UPS to deliver me one.

If you enjoyed reading about "Busted Lyman Turbo 600" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
If you enjoyed reading about "Busted Lyman Turbo 600" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!