Glock 19 trigger issue


PDA






jlott00
March 28, 2011, 07:28 PM
i polished the parts of my trigger on one of my g19's......by hand.
Now as im shooting the trigger gets harder and harder to to fire, until im forced to pull just the back of the trigger group out and put right back into the frame...
some how this starts the process over again...it will feel great then, but with ever shot/OR DRY FIRE it becomes harder and harder again. have i made a noobie mistake with the re assembly? i dont see how i could have done anything serious to the gun.....

If you enjoyed reading about "Glock 19 trigger issue" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
PO2Hammer
March 28, 2011, 08:30 PM
Me thinks you polished right through the plating.
When you re-assemble the fresh lube keeps the trigger smooth, as you fire/dry fire, the lube moves away and the rough steel starts dragging.

jlott00
March 28, 2011, 08:36 PM
wouldnt you be abel to tell if the plating was polished through?

PO2Hammer
March 28, 2011, 08:45 PM
Yes, when I did it, I could just see the copper layer at the edge of the area that I wore through, but the steel underneath looked very similar to the plated area. It's not real obvious.

I've heard that Glock no longer uses an intermediate copper layer, but I find that hard to believe.

jlott00
March 28, 2011, 10:02 PM
oh i figured it out, i did not polish through...just had a brain fart...needed a drop of oil lol

If you enjoyed reading about "Glock 19 trigger issue" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!