mossberg 500 slam fire


PDA






Tokarevsrule
April 30, 2011, 07:02 PM
I was shooting my mossberg 500e today when I had accidental discharge. When I shut the slide, it went off. The hammer had never fallen!:eek: I could tell because the the little button you unlock the slide with was still set.
How could happen and how can I fix it. BTW I also had a failiure to reset the trigger too.
Thanks

If you enjoyed reading about "mossberg 500 slam fire" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
mnrivrat
April 30, 2011, 07:32 PM
If the hammer had not fallen then the firing pin is either bent, broken, or has fouling preventing it from coming backwards. (frozen in position)

kozak6
April 30, 2011, 10:14 PM
Sounds like you may wish to call up Mossberg and send it in.

1KPerDay
April 30, 2011, 10:17 PM
Sounds to me like your trigger group is messed up, particularly if you're having failure to reset. I betcha a nickel the hammer did fall. Has anyone worked on the trigger group? Send it in... that situation is very dangerous as you know.

Tokarevsrule
May 1, 2011, 08:03 AM
The hammer did not fall. I pulled the trigger after the shell fired and it went click. And the the catch was still set. Even holding the gun barrel down could not get the firing pin to come forward.

bigfatdave
May 1, 2011, 08:16 AM
1- Does the FP come out for inspection on that model?
2- Could something stuck in the FP's opening in the boltface have struck the primer? (how hard were you slamming the action shut?)

If you enjoyed reading about "mossberg 500 slam fire" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!