M&P misfire issue (and solution)


PDA






Guns&Religion
June 10, 2011, 12:54 AM
I bought an M&P40c last year. I was a little bothered though, by a problem I encountered with it. It would misfire about once every hundred rounds. That is to say, I would pull the trigger, and hear the "click" on a live round, but no discharge.

I then read on a couple of S&W forums about how the striker can develop problems if too much oil is applied to it. In these cases, the oil will mix with the powder residue and form a kind of gritty sludge that binds up the striker.

I decided to test the claim, and when I cleaned the pistol, I also took out the striker. After cleaning it, I put a Q-tip into the "compartment" (I'm not sure of the correct term), and cleaned out quite a large amount of the gritty black sludge. I immediately noticed a difference in how the firing pin an spring worked, it was definitely smoother.

So far, I've taken it to the range once since, no malfunction so far.

Here's a good video on how to remove the striker assembly.

http://www.youtube.com/watch?v=L9GXtxmSRDk

If you enjoyed reading about "M&P misfire issue (and solution)" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Snowdog
June 10, 2011, 01:02 AM
Hey, thanks for that info!

I just bought a M&P40c a few days ago and on my first trip out experienced a failure to fire. I just attributed the failure to the ammunition as the primer displayed a good pin strike (Gov't "2nds" Fed EFMJ).
I had no similar issues with the 200 Winchester white box and Rangers that followed.

I'll take a look at the firing pin channel to see it the culprit lays there.

batex
June 10, 2011, 06:34 AM
Sounds like you just need to make cleaning the firing pin channel part of your routine cleaning. I would highly recommend this, even on new guns. I once bought a new-in-box 1980's Colt 1911 Delta Elite and decided to break it down and clean it before testing it out. Thank goodness I did. The firing pin tunnel apparently had not been cleaned out after the machining/drilling process and was absolutely full of metal shavings from manufacturing. You would not have believed how much metal came out of it. How they even got the firing pin and spring installed I'll never know. This was a Colt from the early 80's which was not one of their better periods, I'm told.

wally
June 10, 2011, 09:19 AM
Actually this eventually can happen to any auto -- striker or firing pin, but with a firing pin gun usually the extractor gums up first causing stovepipes.

ForumSurfer
June 10, 2011, 10:18 AM
Actually this eventually can happen to any auto

Yep. I had a buddy who consistently over-lubed has glock and I discovered the same issue with his. He would also clean the darn thing every 200 rounds religiously, even if we were in the middle of a shooting session...it was an annoying quirk. Once we got the goop out of his, I jokingly mentioned that I was somewhere around 7-800 rounds with no cleaning or reapplication of lube. He nearly fainted.

If you enjoyed reading about "M&P misfire issue (and solution)" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!