Pt 24/7 pro ds


PDA






Benzene
November 5, 2011, 10:24 PM
Some time ago I bought a PT 24/7 PRO DS pistol in .40 S&W caliber. Yesterday I took it to the range and had a horrible experience when using Remington UMC ammo. I had to rack the slide for almost every shot! I'm unsure what was the problem: magazine, ammo, something else. Thanks for sharing any advice/experience.

If you enjoyed reading about "Pt 24/7 pro ds" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
gearhead
November 6, 2011, 12:24 AM
The Remington UMC is a little weak, you might need to break in the recoil spring a bit. Was it not ejecting cleanly, not feeding properly, what exactly was it doing?

Benzene
November 6, 2011, 01:11 AM
Thank you, gearhead. It was not feeding properly. I had to rack the slide for each round to get in place.

ritepath
November 6, 2011, 06:15 PM
Was it nosediving the rounds into the magazine?

gearhead
November 6, 2011, 07:20 PM
Were the rounds nosediving, were they hanging nose-up entering the chamber, or were they just not going into battery properly?

I found that my magazines had some preservative inside them and on the mag spring when new so I disassembled all the magazines and cleaned all the parts with gunscrubber prior to first use. I also found a rather prominent mold line around the bottom edge of my follower, I filed that down nice and flush all the way around. I have had no issues at all with feeding on mine. Not sure if the fluff 'n buff prevented any issues but it sure didn't hurt.

Benzene
November 6, 2011, 09:22 PM
Thanks for the suggestion about cleaning the magazine. The rounds are simply not going into battery properly.

If you enjoyed reading about "Pt 24/7 pro ds" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!