Stevens 12 ga. pump problem


PDA






texasred777
February 15, 2012, 01:40 PM
I have a Stevens 67 series E. 12 ga., pump shotgun with a problem. Not everytime, but maybe once in 7 or 8 shots, the slide will not move unless the release is pressed. If there is one shell or more in the mag, it still does this. It gets rather frustrating when you need to make a second shot quickly, and the slide won't move until the release is pressed. I haven't taken the gun apart yet. I thought maybe someone might know what I should be looking for when I do take it apart. Thanks a lot for any and all info and comments. It will be greatly appreciated.

If you enjoyed reading about "Stevens 12 ga. pump problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
rcmodel
February 15, 2012, 02:32 PM
I believe that gun has an inertia slide release that lets go when recoil un-sets it.

It could just be gummed up with old oil & dirt.

First thing you always need to do with a problem like that is to get the trigger group & bolt out and give it a good oil change.

rc

Friendly, Don't Fire!
February 15, 2012, 03:17 PM
I agree with rc.
Carefully disassemble it and clean every single part and get any old, gummed-up oil and grease out of there!

I did that to the same gun and when I completed assembly, the gun is just like a brand new gun! It was my dad's and, although we hunted a lot together, he only ever really put no more than about two boxes of shells through the thing! I remember when he bought it around 1967 at Sears!

texasred777
February 16, 2012, 09:46 AM
Thanks a lot! I didn't think of that. Although a gun is spotless on the outside, it can be dirty inside. I have a Colteer that was almost impossible to pull the bolt back to load the first shot. I took it apart, cleaned it, and it works like a new one. AND, no, I have never taken this pump apart. I'll let you know in a few days what I found. Again, thanks for the info.

smokjunkee
February 16, 2012, 11:49 AM
Is it possible for newer models to have a different slide-release action?
I bought mine in the early 80's and my slide will release when I pull the
trigger on a snap-cap(so no inertia).
SJ

texasred777
February 17, 2012, 08:53 AM
I don't know just what the differences are on the older and newer models. I'm not sure how old this gun is. I've had it since the mid '80s; got it in a trade. Apparently it is a later model because it has the choke tubes and the vented rib.

texasred777
March 3, 2012, 10:33 AM
Well, I finally got around to taking the 67E apart. No, it's not inertia operated. The hook on a spring that is supposed to be caught by a pin on the hammer was bent. I worked with the spring for quite a while before the hammer would catch it. It seems to be working now. I won't know for sure until get a chance to take it out and try it. I'll let you know!
Again, thanks for all the help!

cornbelt
March 5, 2012, 09:51 PM
This is good news. I was working on one of these today and haven't gotten anywhere. I figured it must be the spring, but just exactly how it needs adjusted has escaped me.

Looking forward to your next post.

cornbelt
March 6, 2012, 08:22 PM
Well, to answer my own question, I ordered the spring since the old one had a lot of pliers tracks on it from previous "adjustments". Then I went ahead and put an upward bend about an eithth inch from where the hook starts. It worked, but I'm still going to change the spring when it gets here.

texasred777
March 7, 2012, 11:01 AM
I really need to order a new spring also. Whether the gun works properly or not. Thanks for the comment and good luck.

texasred777
April 30, 2012, 09:01 AM
I finally took the pump shottie out to try it. After only a couple of shots, the slide started locking again. I'll try to get back into it in a few days.

If you enjoyed reading about "Stevens 12 ga. pump problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!