Walther PPQ mag problem


PDA






wow6599
March 31, 2012, 06:01 PM
I have a new PPQ that I took out to the range today for the first time, along with 5 magazines - all OEM, PPQ magazines. One of the mags will not hold the slide open after the last round is fired. I shot Federal 115 gr. WM stuff and Speer Gold Dots - about 200 rds total. The 4 other mags worked fine, but the one didn't. I tried it full, -1, and with 2 or 3 in it......didn't matter.

When i got home and cleaned the gun, I broke down the magazine and couldn't find any problems; clean, set-up right, good tension, etc.

Any opinions on what it could be?

If you enjoyed reading about "Walther PPQ mag problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
balance 740
March 31, 2012, 06:26 PM
The only thing I would think it could be is if the follower on that mag isn't lifting the slide release high enough to catch on the slide.

If you rack the slide by hand, does the slide lock back? Is the spring the same length as the springs in the other mags, with the same amount of coils?

A call to CS will probably get you a new mag sent out to you.

wow6599
March 31, 2012, 06:30 PM
If you rack the slide by hand, does the slide lock back?

Yes.

Is the spring the same length as the springs in the other mags, with the same amount of coils?

Yes.

balance 740
March 31, 2012, 06:34 PM
Does the notch on the follower that rises to activate the slide release lever on that mag, rise to the same height as the notch on the other mags? Does it rise to that level freely within the mag body?

Did you fire only Federal Champion through this mag only?

Bovice
March 31, 2012, 07:25 PM
I have had strange magazine problems with new magazines before that were solved by taking them apart and reassembling them. I don't know what changes things over the course of that event, but it works.

EDIT:

I just read that this is a brand new gun. You likely need to fire it a few times to work in the recoil spring, it may be slightly too stiff. Lock the slide back for 24 hours and I bet it will go away.

wow6599
March 31, 2012, 11:07 PM
I appreciate all the ideas / suggestions. I'm sure Walther (S&W) will replace it.......at $50 a pop, they should work.

chieftain
April 1, 2012, 12:20 AM
About 4 years ago I bought a brand new Glock 19 of course third gen at that time. As in your case neither magazine would lock on the last round.

Apparently Glock had changed the generation of magazine followers to the, IIRC the 6th gen follower. I had something else that obviously didn't work.

Glock didn't send me new magazines, just new followers. Not a problem of course, and the new followers ran fine.

I am sure Walther will rise at least to that level of service. Just for the record, my PPQ and 12 magazines run just fine. 4 of them are the factory 17 rounders.

I am sure you will be happy with your PPQ. Good luck.

Fred

searcher451
April 2, 2012, 09:18 AM
Sounds like a follower issue to me, or perhaps it's gunked up. Call or email the WaltherAmerica/S&W hotline and let them know what's up. The chances are good that they will send you a new mag, no questions asked.

If you enjoyed reading about "Walther PPQ mag problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!