PJK9P problem


PDA






p35
April 13, 2012, 02:46 AM
I have an FEG PJK9P Hi-Power clone. A while ago I field stripped it for cleaning, and now I can't get it back together. The feed ramp keeps hitting the recoil pin (if that's the right term- the crossways pin that the slot under the barrel normally engages) so that the slide won't go all the way back on the frame.

Just to be sure I wasn't crazy I pulled out a real Browning and took it apart. As far as I can tell all the parts are identical, and it went back together with no problem- same as it's been doing for the twenty years I've owned it.

I was half inclined to grind a little off the bottom of the feed ramp, but I reminded myself that it's been together and working so there must be a way to do it. Taking metal off the feed ramp seems like a recipe for trouble too.

This is driving me nuts. So, any comments/suggestions?

If you enjoyed reading about "PJK9P problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
tekarra
April 13, 2012, 11:37 AM
If it worked properly before, I would keep looking for the problem. Do you have a manual for the pistol? If it is indentical to the Browning, use the Browning manual. I would not grind on the feed ramp.

Hammerhead6814
April 13, 2012, 09:19 PM
The feed ramp is hitting the recoil pin? Do you mean the pin that holds the recoil spring in place? I can't see that hitting the feed ramp.

Please post some pics. What your describing right now sounds impossible. I think what you are saying is the barrel is hitting the slide stop. Or maybe the magazine safety.

jonnyc
April 13, 2012, 10:00 PM
Do you have the recoil spring guide the right way 'round?

If you enjoyed reading about "PJK9P problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!