Problem with Sig 556


PDA






briansmithwins
April 27, 2012, 12:49 PM
Being paranoid, I checked my Sig 556 gas valve for relative port sizes. Sure enough, the ports are backwards: The larger port is in line when the tab is straight up and down (normal), the smaller one lines up when the tab is over to the Sig 550 'adverse' setting.

I did think the action was being cycled rather smartly and the brass was getting tossed rather far.

So far I've called Sig CS and have been promised a new gas regulator.

Anyone else had this problem and how did Sig correct it?

So, timeline so far.

8Apr: Discovered my gas regulator was drilled backwards.

9Apr: Called Sig CS and was told replacement part would be shipped.

19Apr: Called Sig CS and asked where part was. CS rep said she had been waiting for info from the gunsmith but he hadn't got back to her. She promised part would be shipped.

23Apr: Received email shipping notice with tracking number. Sig shipped Fedex ground with a estimated arrival date of 30Apr. (Thanks Sig for choosing the slowest delivery method possible.)

BSW

If you enjoyed reading about "Problem with Sig 556" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
stubbicatt
October 27, 2012, 03:34 PM
When it came, was the new regulator correct?

If you enjoyed reading about "Problem with Sig 556" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!