Help. New Ambi safety on DPMS over-rotates.


PDA






Northslope Nimrod
June 27, 2012, 10:32 PM
I just installed a DPMS Ambi safety on my DPMS LR AP4 308. Seems to work except: 1) The safety sticks out on both sides a bit, which I was expecting due to reviews; 2) The safety doesn't have any positive click when going on and off safe AND will rotate about 360 degrees.
Is there anything I can do to fix this?
*Also, I just noticed that if the safety is pressed all the way to one of the sides (given the play mentioned above) the safety won't disengage. If pressed to the other side, it works fine.

If you enjoyed reading about "Help. New Ambi safety on DPMS over-rotates." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
MrCleanOK
June 27, 2012, 11:52 PM
Are you sure you didn't lose the safety detent and detent spring that live in the grip and receiver below the safety?

madcratebuilder
June 28, 2012, 09:06 AM
The detent and spring are the first thing to look at. It's under the hand grip.

Check the end of the detent, it should have a rounded point and be smooth. Check the safety selector detent pocket, make sure it does not have any casting flash or imperfections. A touch of light grease on the safety selector detent pocket well make it turn smoother.

*Also, I just noticed that if the safety is pressed all the way to one of the sides (given the play mentioned above) the safety won't disengage. If pressed to the other side, it works fine.

It's probably hitting the trigger tail when it's pushed to one side, you may need to stone it for clearance.

Gtimothy
June 28, 2012, 09:07 AM
^^^^ What he said! If you didn't put the spring or detent pin back in or if it is not sitting in the channel right, you will have the problems you have described.

Northslope Nimrod
June 28, 2012, 07:16 PM
I put the detent back in and the spring but I will remove the grip and check everything.

rcmodel
June 28, 2012, 09:41 PM
You might have bent & crushed the end of the spring compressing it when you put the grip back on.

Got to be that, or it or the plunder isn't in there at all.

rc

Northslope Nimrod
June 29, 2012, 12:59 AM
I removed the spring and detent, put them back in, careful to have it straight. The safety still rotates too far, and if I push it back and forth (using the space on the sides of the receiver since the safety is too big as mentioned above, which is normal) the safety won't always disengage. Example: I select fire, pull trigger and it fires. But if I select fire then bump the safety to the other side (to left of receiver, for expample), then it won't fire.

I removed the spring and detent a second time, put some grease on it. Still same result. :banghead:

madcratebuilder
June 29, 2012, 07:57 AM
DPMS Ambi safety in a LR-308 should work just fine. Call DPMS CS they may send you a replacement. These are very simple parts, they work or they don't. Maybe you got one with funky machining dome to it.

Did you inspect the detent pocket in the safety? The safety handle on the right side, the one the uses a screw, is it fully seated in it's notch? There should be less than .020 side to side movement. I have several bad-ass safeties and they have about .006 side to side movement, my LMT is about the same.

The detent seating in the safety pocket is what controls side to side play. You have the correct spring in there?

The selector spring is .904 long, .10 diameter with 28 coils. Some detents are pointed on both ends, some only on one end. Make sure the pointed end is going into the selector pocket.

rcmodel
June 29, 2012, 02:43 PM
Beg borow, steal, or buy a #22 drill bit.

Then "finger turn" it through the detent hole in the lower.

It may be a burr or finish build-up in the hole keeping the plunger from going out all the way.

rc

If you enjoyed reading about "Help. New Ambi safety on DPMS over-rotates." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!