M&P question


PDA






Carter
July 13, 2012, 10:59 PM
The other day I was at qualifying event for the M&P. It had been raining heavily and the instructors left the guns out in the rain. Some of them had literally been submerged in water for an extended period of time.

While shooting, the person next to me and my gun kept ejecting the magazine. Neither one of us were pressing the mag release. After that issue stopped, my M&P wouldn't pick up rounds from the magazine when cycling after the first shot, and would occasionally partially eject the mag as well.

Now I know training weapons aren't the most well cared for weapons, but is this normal for M&P's?

I've come to love their grip, sights, and even the trigger, but this issue is a bit troubling.

If you enjoyed reading about "M&P question" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
tarosean
July 13, 2012, 11:19 PM
I have a 45c never had a single malfunction. However, can say I've never had mine submerged?

Ar180shooter
July 13, 2012, 11:31 PM
Not normal at all. However, I would suspect that insufficient maintenance and lots of rounds through it combined with the rain had something to do with the reliability issues. As for the magazines dropping out, it's possible that the magazine release was switched to the left side, then switched back, but not properly reinstalled (not sure how that would happen though), or the magazine release is damaged, and is not catching the notch in the magazine fully.

LightningMan
July 14, 2012, 12:30 AM
This is only a guess and cannot be taken for fact, but my best guess is that maybe the mag release button swelled/enlarged and combined with all that carbon residue mixed with the rain causing it to stick. I know from my cowboy shooting guns, that if I shoot them during a match and it rains heavy, the stocks will swell and they are very hard to remove. Specially the rifle and shotgun stocks. Remember this is only a guess, and it could be something totally else. LM

Skylerbone
July 14, 2012, 12:43 AM
Some early production M&Ps did have this issue, I believe in .45ACP. You may wish to have your armorer check the S/N range and place a call to S&W about the problem. I do hope you mentioned it at the time. Google or the search feature may sort out which models were affected.

If you enjoyed reading about "M&P question" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!