Gemtech Multimount end view question.


PDA






wally
November 11, 2012, 06:35 PM
Picked up my 9mm Gemtech Multimount yesterday and was wondering what up with the line of "divots" on the core elements?

Virgin can, never seen a round as far as I can tell. I thought they test fired them at the factory?

See the photo. Alignment meets all the tests I can make on my Uzi so I hope to give it a go tomorrow.
http://www.thehighroad.org/attachment.php?attachmentid=174578&stc=1&d=1352673185

Edit: I know this is "normal" as I've noticed them on every photo of a Multimount showing the end baffle.
Just wondering if anyone knows why its there?

If you enjoyed reading about "Gemtech Multimount end view question." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
wally
November 11, 2012, 07:07 PM
As long as the camera is out, I should show a couple of photos of my new toy :)
I've had the Uzi since the '80s (original "model A") and recently did the SBR, should have done it years ago!
http://www.thehighroad.org/attachment.php?attachmentid=174581&stc=1&d=1352675082

http://www.thehighroad.org/attachment.php?attachmentid=174582&stc=1&d=1352675082

Mot45acp
November 13, 2012, 02:17 PM
I have a HALO that has the same divots.

I just noticed then the other day and got real concerned. But closer inspection shows no signs of baffle strike. No copper shavings, disfigured metal etc. must be part of the manufacturing process. It may have something to do with funneling the gasses is a certain direction.

If you enjoyed reading about "Gemtech Multimount end view question." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!