Browning Buckmark FTE issues: True or False?


PDA






bird466
November 30, 2012, 06:00 PM
I have been churning through the forums trying to find possible solutions for my Buckmark Camper's FTE problem. I've only used CCI Stingers and Federal Bulk ammo (550rd pack) thus far. The Stinger's tend to work a bit better; however, either way I go ammo wise, I usually get at least 1 if not 2-3 FTE per magazine. I have 3 magazines and it's pretty consistent. Any suggestions?

I upgraded the barrel with a Tactical Solutions Trail-Lite; the problem existed before and it continues now. From what I've read, Buckmarks can be picky about their ammo diet. At the same time, I often see a lot of Buckmark owners that say they've fed thousands of rounds of whatever without issue. I know that a bold statement like that can hold true with Glocks, but 22's???

Furthermore, I came across the Volquartsen Exact Edge Extractor. Unfortunately, I didn't notice at the time of purchase that all the positive results from this upgrade (that I saw on the forums) were geared toward the Buckmark Camper's rival .22 (the Ruger MKII/MKIII).

So in addition to my Buckmark FTE question, my secondary question is... Although the extractors are slightly different in design (the Buckmark has a unique notch in the inside "flat" section of the extractor whereas the Ruger's is just flat), do you suppose the Volquartsen Exact Edge Extractor can work in a Buckmark Camper?

In advance, I appreciate you all taking the time to answer these wildly ignorant questions. But alas, they must be asked nonetheless.

If you enjoyed reading about "Browning Buckmark FTE issues: True or False?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
railroader
November 30, 2012, 07:40 PM
I've had a standard buckmark for over 10 years without extraction or ejection problems. How old is your gun and have you contacted browning? As for ammo try some blazer bulk ammo. It seems consistent and reliable.

viking499
November 30, 2012, 08:33 PM
I have two Buckmark URX pistols. Only a couple hundred rounds through each, but no problem with either so far.

I mostly shoot HV American Eagle or blue box CCI. Both 40 grains.

wally
November 30, 2012, 10:09 PM
Check the ejector. Its a wire like thing attached to the frame, after 5-6000 rounds through my Wife's pistol it got bent somehow and she started having ejection failures all of a sudden. I bent it back into proper position and its been fine since.

Its not the least bit picky of about ammo.

If the empty rounds are stuck in the chamber your problem is clearly something else. FTE is ambiguous. Photos of the failure would make it clear.

Changing the extractor won't help if the problem is the ejector.

marklmurray
November 30, 2012, 10:15 PM
...FTE is ambiguous...

This has been a pet peeve of mine ever since I learned these initialisms. I have always advocated using 'FTX' for Failure to extract and FTE for Failure to eject.

Now, what to do about FTF?

wally
November 30, 2012, 10:22 PM
Now, what to do about FTF?

Spell it out! FTFeed vs. FTFire FTEject vs. FTExtract.

Photos of the failure are better still!

Steve C
December 1, 2012, 04:16 AM
The extractor is only used for clearing the chamber manually and as a pivot for the case during ejection. When the gun is fired the case being expelled out of the chamber is what forces the slide back and the ejector is what kicks it out.

On the rare occasions when my Buckmark as failed to eject the round, it has always been an issue of cleaning and lubrication. Problem is solved by cleaning the chamber as well as the rest of the gun. After a good cleaning it will usually run a season of 10 matches without needing another cleaning.

wally
December 1, 2012, 04:47 AM
The extractor is only used for clearing the chamber manually and as a pivot for the case during ejection.

True enough, but the "pivot" function is crucial for reliable function. If the empty is off the extractor before hitting the ejector it'll bounce around the opening and can be caught by the slide on its way forward causing a "stovepipe" jam.

bird466
December 2, 2012, 04:00 PM
I've read about the ejector (wire thing) being an issue. It looks fine to me. However, which direction should it go. I've read up and inwards (and that's what it looks like). I'll be posting pics soon; however, due to the camera perspective, it's hard to get the right angle anyways.

Also, I have a tendency of over working and over torquing things; I don't want break what's possibly not broke.

The gun was bought from a friend who's wife didn't care for it. He said it was basically new out of box. Perhaps, I need to run a couple bricks to get it settled in?

Side note: I bought this piece to appease that inner voice calling for more range time while supplementing my wallet from the ever increasing costs of 45ACP. Basically, I just want that Buckmark glory to shoot whatever... accurately! ...and cheap!

Oh, and to be more specific about the problem... It's a bit of failure to fire and failure to eject the spent casing. Normally, I'll shoot off some rounds and then one won't go bang. I'll rack it back, spit out a good round, and then continue until it happens again. But this last time at the range, the casing stayed in. I had the range master pry is out with his utility knife. Possibly just a bad .22 (it was bulk), I don't know. But after shooting over 350 plus rounds through it (over the lifetime I've had it & including breakdowns/cleanings) and the FTF happening more frequently, I need some reassessment time. Again, any help is appreciated. Do you think it's worth sending the gun to Browning (s&h, wait times, headaches?, etc..)?

bird466
December 2, 2012, 04:33 PM
Here's a link to another member's post having similar issues...
http://www.thehighroad.org/showthread.php?t=280016

At this point, it's cleaned up, lubed, and ready to be tested at the range again. I'm gonna try an assortment of ammo and see if that makes a difference. Hard to put my finger on this issue though since it appears to be evolving. I've even had a casing get stuck during its ejection process. Ugh.

bird466
December 2, 2012, 10:11 PM
Solid advice, thanks!

As soon as I purchased the gun, I got a Tactical Solutions scope base. When I installed it, those special washers didn't fit right. So I just used the screws provided with the base. Well, now I took off the base and reinstalled the original with the concave washers, screws, and some blue loctite. I'm hoping that does it.

MaterDei
December 2, 2012, 10:15 PM
When the two screws holding the rail on top of the gun in place become loose bad things happen. Keep them tight and the problems go away.

Guillermo
December 2, 2012, 10:22 PM
When the two screws holding the rail on top of the gun in place become loose bad things happen. Keep them tight and the problems go away.

he beat me to it

The only problem that I have had with either Buckmark that lives at my house stem from loose screws.

Locktite and tighten and keep the proper Allen wrench in the range bag.

Fishbed77
December 3, 2012, 10:20 AM
bird4664,

I gotta ask - did you fully disassemble, clean, and lubricate the new Buck Mark prior to shootng? I ask because my brother had the same problem with his Buck Mark camper when it was new. A good cleaning (there was a lot of preservative grease in there) and lubrication solved the problem.

bird466
December 3, 2012, 11:47 AM
Hello Fishbed77. No, the first thing I did when I bought it was take it to the range (perhaps, I should have done the smart thing and take it apart first). That's when I experienced the Failure-to-Fire problems (2-3 rounds per 10rd magazine). Took it home and ran a bore snake through it a number of times with Hoppe's 9.

Later on, I upgraded the barrel with the Trail-Lite and installed the scope base (sans the concave washers and original screws). The barrel was new, so I didn't think to clean or lube it. At the range, I had the same FTFs with the additional FTX (Failure to Extract).

Since then, I've disassembled the top part of the gun and cleaned it thoroughly (using this YouTube video... http://www.youtube.com/watch?v=9uKc7JxyJ8g). I recently found a website showing how to disassemble the bottom section. Is that what you're recommending? Also, do you have recommendations for spots to lube? I'm a Glock owner too (so I'm kinda lazy, LOL). But I served, so I'm not afraid to clean.

Prince Yamato
December 3, 2012, 02:57 PM
Use 40gr ammo. That's what I discovered. I run a suppressed buckmark and it chokes a lot with 36gr.

If you enjoyed reading about "Browning Buckmark FTE issues: True or False?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!