Loose shell latch on an 870


PDA






Gato MontÚs
January 18, 2013, 01:41 PM
I had my 870 Wingmaster stripped down as much as I could in preparation for sending her off to be engraved for a SBS build. While everything was apart, I tested the fore end assembly with a new piece of furniture on the bare receiver racking it a few times to make sure I didn't mess up the action bars. Come to take the assembly off, I can't depress one of the feed latches and realized that without the take down pins installed I hammered the right shell latch into the mag tube!

Now, I was able with some force scoot it back into position with a screwdriver, and it doesn't look like it's going to jump it's channel any time too soon, but I really don't know if this is a problem or not? For all I know, the staking originally could have been so light that the only thing holding it in was the take down pin and it wasn't until I worked the action bars without the pins installed that this was revealed.

Point is I don't know how common this is and whether or not it can just be ignored OR if this thing is now one step closer to jumping out with everything installed jamming up my gun in a real bad way. I see a tool listed on Brownells that's purpose built for this, um, purpose, but I really rather not drop $40 on a tool I'll probably use once, if at all. If anyone has experience with this I'd love to hear it.

If you enjoyed reading about "Loose shell latch on an 870" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Fred Fuller
January 18, 2013, 03:18 PM
The trigger plate assembly and the takedown pin help hold the shell latches in place - the staking is to hold them when the shotgun is field stripped and the trigger plate assembly is removed. It's not a good idea to run the action without the trigger plate assembly in place IMHO.

If you relocated the slipped shell latch properly and reinstalled everything correctly, it should be OK unless you damaged the right shell latch.

Gato MontÚs
January 18, 2013, 03:47 PM
It's not a good idea to run the action without the trigger plate assembly in place IMHO.

Ya, you got that right!

I reassembled after the incident and did a function test without any problems, so I believe I'm in the clear.

Thanks Fred!

If you enjoyed reading about "Loose shell latch on an 870" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!