Safety won't stay on Mossy 500


PDA






dukefan70
February 2, 2013, 06:50 PM
Mossberg 500 20g. Doubles as HD gun and skeet gun. Never had a problem with this when I tested my HD loads when I got the gun. First noticed when shooting skeet that sometimes the safety would move from recoil and mess up the next shot. The original plastic safety button popped off while shooting skeet a while back so I got a new aluminum safety button and locktited the screw down. I'm still having the same problem. Do I need a stronger spring in the safety or what? Obviously it's not a reliable HD gun until this is resolved.

Thanks in advance.

If you enjoyed reading about "Safety won't stay on Mossy 500" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Black Knight
February 2, 2013, 07:32 PM
There is supposed to be a small ball bearing under the safety. It sounds as if this ball bearing was lost when the safety came off. You need to remove the current safety and replace the ball bearing. Then put the safety back on.

dukefan70
February 2, 2013, 08:09 PM
Black Knight, the issue was happening before the original safety button popped off. I remember assembling it with the new safety button and I'm almost positive I got the ball bearing and spring back in place properly. How could I forget, it was such painstaking process to get it back together WITHOUT losing the ball bearing.

Black Knight
February 2, 2013, 09:12 PM
That was the only thing I could think of that might cause the problem. You would be surprised at how many people forget about the ball bearing or even know it is there. I didn't until I took their armorer's course. Is it possible that the safety block is worn and not allowing the safety slide button to maintain tension? You may need to give Mossberg a call.

rcmodel
February 2, 2013, 09:21 PM
You may need a metal safety, ball, and spring too.
The plastic one sucks.

http://www.brownells.com/shotgun-parts/receiver-action-parts/safety-parts/safety-hardware/mossberg-500-590-835-safety-kit-prod27426.aspx?ttver=2


http://www.brownells.com/shotgun-parts/receiver-action-parts/safety-parts/safeties/mossberg-500-590-oversized-safety-prod19517.aspx?ttver=2

rc

dukefan70
February 2, 2013, 10:50 PM
Black Knight, I found a pic of the safety block so I know what piece you mean. I suppose its possible, but I would be surprised/disappointed if anything was worn out; I bought it new 4 years ago and haven't exactly shot a ton of skeet with it, and only occasionally taken it to the firing line.

rc, the safety button in the first link you posted is the new safety button I put on. Are you saying I should just get a new spring and ball too and try that?

I kind of like the placement of the tang safety on the 500, but I have to say my father's 870 with the push button safety to the rear of the trigger guard really CANT have the problem I'm having.

rcmodel
February 2, 2013, 11:09 PM
Are you saying I should just get a new spring and ball too and try that?Couldn't hurt.

Folks have been known to put a kink in a new spring while installing a new safety.


BTW: I agree with you 120% on the cross-bolt safety that was standard on all shotguns until Mossberg invented a "better way"" to do it.

It's just hard to improve on a safety that never fails, and allows you to keep your thumb wrapped securely around the pistol grip to maintain total gun control while using it with a trigger finger.

It certainly forces you to keep your Booger-Hook off the Bang-Switch when using the safety now doesn't it!!

And they work with pistol grip stocks too!!

rc

dukefan70
February 3, 2013, 02:41 AM
Well at this point I might as well go after the spring and ball. I'm gonna try and see if I can get them apart from the safety kit and save $$ since I already have the new button.

So all pumps used to be have crossbolt safeties, eh? That Mossy 20g was my first gun ever when I got my license, and I've got no other complaints, but the safety going on between rounds fired is kinda a BIG complaint. I'm curious now to do some looking and see if anyone else has had this problem. For all the "500 vs. 870" threads on here (Lord knows I haven't read 'em all), they always seem to come out even on function.

If you enjoyed reading about "Safety won't stay on Mossy 500" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!