Help Scope 'slipping'?


PDA






ExAgoradzo
February 2, 2013, 11:57 PM
Last time I went to the range I was putting my .270 Win about 1.5" at 100 yards. I've been hunting 4 times since (hog). Today I had time so I wanted to verify zero. I was disappointingly high and right, so I adjusted accordingly.
Long story short, a whole box of ammo, my friend and I (who is a better hunter than I) could not get it into adjustment and as soon as we started playing with it the gun started shooting all over the place about 6" or so (ave) high. Both of us shot his gun and we were just fine on target (his groups were smaller than mine :( ).
He said something about scopes 'slipping'. I don't know how old this Weaver CVIO Micro-Track 2-10x40 is. I inherited it along with the gun.

So,
1. Can I 'rebuild' a scope?
2. Am I missing something?

Thanks,
Greg

If you enjoyed reading about "Help Scope 'slipping'?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
NeuseRvrRat
February 3, 2013, 12:06 AM
how is the scope mounted? what brand of rings/bases/whatever you used to mount it?

no, you can't rebuild a scope

The Kidd
February 3, 2013, 12:12 AM
First thing to do is to check all your mounting screws,( bases, rings) and use Loctite Blue to keep them tight.

ExAgoradzo
February 3, 2013, 12:47 AM
They are Weaver rings. They look solid. I tried to jiggle the outside of the scope and it is fine. Tristan thinks it is on the inside that is the problem...

Greg

The Kidd
February 3, 2013, 01:32 AM
It may be your scope is dead but... if it is just loose it is quick and easy to fix. That is why I would check that first.

TurtlePhish
February 3, 2013, 01:35 AM
It sounds like something might have gone on the inside of the scope. Unfortunately, you may have to replace it. Swap it with another scope and see if that's the case. If the problem persists, it's not the scope itself, but probably the mounting hardware.

ExAgoradzo
February 3, 2013, 01:36 AM
Good idea, I'll check another scope, if I can borrow one. Anyone live on the Central Coast of CA? ;)

Greg

TurtlePhish
February 3, 2013, 01:38 AM
I've got a cheap Bushnell 3-9x32 in the basement. It's not much, but it's something. Yours for the cost of shipping if you want it.

rcmodel
February 3, 2013, 01:48 AM
Scope "slipping" means it is slipping in the rings and moving in the mount.

"Paint" it in with a dab of model paint at the ring scope tube joints, and if the paint cracks the next time your shoot it?
It is slipping in the rings.
If the paint didn't crack, yours didn't slip, it broke

In other words, your old scope has bit the big one, and it is time for a new scope.

BTW: Tighten the rifles action screws and use copper solvent to clean the bore before you give up on the scope.


rc

ExAgoradzo
February 3, 2013, 01:56 AM
Thanks RC, I'll try both ideas!
Greg

Abel
February 3, 2013, 07:55 AM
He said something about scopes 'slipping'. I don't know how old this Weaver CVIO Micro-Track 2-10x40 is. I inherited it along with the gun.


Maybe he didn't mean slipping. Maybe he just meant it was no good anymore. Get a new Redfield 3-9x40mm and remount the bases, just to be sure that everything is good and snug. Actual torque specs are available for the rings and bases if they are really Weaver. I just tighten them to a place that is tighter than just snug, but not super tight that I may be stripping a screw or bending the scope tube. I also put about half a drop of BLUE loctite on each base screw.

Welding Rod
February 3, 2013, 04:17 PM
You weren't resting the barrel (rather than the back of your hand and/or or the stock) on a support while you were shooting were you?

ExAgoradzo
February 3, 2013, 05:22 PM
I was using sandbag rests and they were under the fore stock, not the barrel.
Greg

rugerman
February 3, 2013, 07:02 PM
I have a friend who has a 270 that he was sighting in for the first time, he could not get it to shoot a group (shotgun pattern). He asked me to help, I took the scope off the gun, checked the action screws, remounted the scope and checked the ring screws. Still would not shoot a group. I told him to come back the next day and we would try my 270 reloads and maybe a new scope (I have a spare). He was using 130gr winchester factory loads so we started with 130 gr speer bullets, better but still a pattern not a group. Then we tried 150 gr sierra sp bt, you could cover the group with a quarter at 100 yards. His gun didn't like 130 gr bullets. So a diferent weight bullet may make the difference.

ExAgoradzo
February 3, 2013, 07:28 PM
Hmm, I'm willing to try bigger weight bullets...esp when recommended by a guy with such a cool name ;).
But that won't explain why the scope didn't respond to the adjusting, just stayed high and wouldn't come down at all...
Greg

If you enjoyed reading about "Help Scope 'slipping'?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!