S&W 625 Problem


PDA






buckhorn_cortez
February 3, 2013, 08:02 PM
I got a new S&W 625 Jerry Miculek revolver yesterday. I took it to the range today and shot 250+ rounds through it and had a consistent problem with light primer strikes when shooting the revolver double action.

As the session went on, the problem got slightly worse so that I would have one light strike every six shots. The problem never happens when shooting the gun single action.

It appears that when using it double action, the hammer is not being pulled all of the way back before it is released causing the light strike. I'm wondering whether the gun just needs better lubrication. I hate taking the side plate off of a double action - all those little levers, etc. But, I may clean the gun, and take a look at the internals for lubrication.

I'd appreciate anyone's thoughts on this.

If you enjoyed reading about "S&W 625 Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
the-ghost
February 3, 2013, 08:19 PM
hammer spring needs to be tightened up, screw is under the grip though i'm not familiar with that exact model.

buckhorn_cortez
February 3, 2013, 08:31 PM
Sounds reasonable - I'll look for an exploded view on line and give it a try. Thanks for the response.

Old Fuff
February 3, 2013, 08:47 PM
The design of the revolver is such that the hammer rotates through a shorter stroke in double-action. This is something that has to be and you can't change it.

It is quite possible that the mainspring strain screw (located near the bottom of the front strap - you have to remove the stocks to see it) may have backed out, and the solution is to turn it back in.

It is not necessary to remove the sideplate to lubricate the lockwork, and doing so may be counter-productive.

Part of the trouble may be that the cartridges are head spaced by the clips, and unlike a rimmed case are not supported by the cylinder's rear face. Nothing much you an do about that, other then using thicker clips or sending the gun back to the factory for examination & correction under warrantee - if something is really wrong.

buckhorn_cortez
February 3, 2013, 09:11 PM
I'll check the strain screw. I checked the cylinder for end shake, but there's virtually zero since it is a new revolver - trying to rule out the obvious. If the strain screw does not cure the problem, I'll take it back to the dealer & let them deal with S&W.

stonecoldy
February 3, 2013, 09:31 PM
My 625 exhibited the same problem, as Old Fuff mentioned; I just pulled the grip off and the screw appeared to have backed out at nearly 3 full turns. Thank you Old Fuff for your sage advice.

Old Fuff
February 3, 2013, 09:34 PM
My bill is in the mail... :D:

Walkalong
February 3, 2013, 10:47 PM
I bought a used 625 and had the same problem, along with it trying to hang up in DA. It was the strain screw loose. Tightening fixed both problems.

Silly me sold it. :banghead:

Ah well.

buckhorn_cortez
February 3, 2013, 11:20 PM
I'll check the strain screw tomorrow after I clean it. If it is not that - I'll take it back to the dealer. He's one of those "old time" gunshops with a gunsmith who's worked on S&W for about 40 years.

Thanks to all for the advice. You've helped immensely.

gamestalker
February 3, 2013, 11:56 PM
It's very likely the strain screw, a common occurance with S&W. Mine have done the same thing.
GS

righteoushoot
February 4, 2013, 08:22 AM
S&W replaced the FP on my model 22 with a longer one.

That gun is 45 acp, but I have heard this being a solution for others as well. But, I would always look for the simple obvious solution first. Lot's of people seem to loosen their strain screws to lighten the trigger pull, but yours was new.

Good Luck.

buckhorn_cortez
February 4, 2013, 10:00 PM
I checked the strain screw and it took 1-3/4 turns to full tight. Hopefully, this will solve the problem. Thanks to everyone for guidance on where to look for a potential solution.

TonyT
February 5, 2013, 11:14 AM
buckhorn cortez,
First I would check and see that the mainspring strain screw on the bottom of the frontstrap is fully tightened.
Second use ammo primed with Federal primers since they have the softest primer cups and are the easiest to ignite. I use Federal primers in all my revolbvers with lightened DA triggers.
You may also wany to consider replacing the factory firing pin with an extra longFP from either C&S or Apex. Removing and installing a new one is a simple task requiring ca 10 minutes.
If you want to lubricate without taking off the sideplate then squirt some RemOil into the mechanism (after taking off the grips).

BlindJustice
February 5, 2013, 05:02 PM
I have a 625 that had the same issue. So, check the strain screw

Also, the stock firing pin is conical, (pointy) I replaced the stock
firing pin with the Apex XP Ignition kit - which is a firing pin that
is longer and round - it works now.

I'll follow up with a link to APex

Randall

BlindJustice
February 5, 2013, 05:07 PM
Apex XP Ignition kit

https://apextactical.com/store/product-info.php?pid4.html


Also Federal Primers - they're softer - are recommended.

R-

SlamFire1
February 5, 2013, 06:13 PM
I had misfires in a 586. The pistol had been used by a gun who shot PPC. He had shot tens of thousands of rounds throught the pistol.

I put in a new mainspring. That fixed it.

If you enjoyed reading about "S&W 625 Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!