Saiga 7.62x39 scope/sighting issue


PDA






Station7
March 9, 2013, 04:14 PM
Hi everyone. I've got a problem with my new Saiga that I can't figure out.
I used Sierra Infinty and decided with my scope height(3") I'd go with a 50 yrd zero. It zeroed just fine at 50 yrds, but when I move to 100 yrds it shoots 11" high.
So far I've tried 2 different mounts, 2 sets of rings, 2 scopes, and 4 different brands of ammo all from a solid shooting bench. It groups just fine even at 100 yrds, just way too high.
I've checked that the barrel, mount, rings and scopes are all level horizontally and vertically. Barrel and crown are great(brand new rifle). I'm at a loss.
Any help would be greatly appreciated. I got this thing to eliminate some hogs, but unless I get this lined out I'm gonna have to get rid of it.

If you enjoyed reading about "Saiga 7.62x39 scope/sighting issue" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
rcmodel
March 9, 2013, 04:24 PM
With that high a scope mount?

The bullet is still going up at 50 yards.

Zero it at 100 yards and it will be shooting a little low at 50.

rc

Station7
March 9, 2013, 04:46 PM
Well maybe I'm reading it wrong, but going by my chart I should be .75" high at 100 then almost 1.25" low at 150. A 100 yard zero shows me being 2.25" low at 150. Where I'm incountering hogs(25-150 yards) is where I wanted a "no adjustment needed" point and shoot kindof situation. Besides the point by the way this things hitting at a 100, a 100 yard zero may make it hit in the dirt at 50 yards.

If you enjoyed reading about "Saiga 7.62x39 scope/sighting issue" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!