CZ SP-01 issue - anyone having problems with the slide lock?


PDA






forindooruseonly
June 15, 2013, 06:47 PM
So I bought this CZ brand new and the slide has never reliably locked back on an empty magazine. Sometimes it does, sometimes it doesn't - and more frustratingly it's not magazine specific. I have four factory magazines and another eight Mec-Gars and they all let the slide forward on an empty chamber half the time.

I was told the CZ is sprung heavy and that it prefers warmer, heavier ammo. As it breaks in, I was told it should get it's act together. That was four thousand rounds ago. The first thousand was S&B 115 gr. ammo that I had a case of, then a mixture of bulk stuff, but the last couple thousand rounds have been reloads on the stout end of the scale - 124 and 147 gr. stuff that is fairly hot. The factory 147 gr. carry ammo I use doesn't reliably lock the slide back either, so I'm pretty sure it's not a power factor issue.

In the gun's defense, it has never hiccuped on any of the wide variety of ammo I ran through it. But the slide's failure to lock back on an empty mag is getting annoying.

Any suggestions?

http://i13.photobucket.com/albums/a263/Forindooruseonly/sp01.jpg

If you enjoyed reading about "CZ SP-01 issue - anyone having problems with the slide lock?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
JDGray
June 15, 2013, 07:40 PM
Weak mag springs? Follower issue? I have the opposite issue with my cz, hold open with ammo in the mag. I keep taking more material off the stop, little by little, it gets better but not 100% yet.

AfghanVetOrcutt
June 15, 2013, 08:21 PM
I've heard of more than a few guys putting weaker springs in but I'm not sure if it's related to that particular issue. I can't say I've heard of anyone with that issue before.

Nice CZ though, I've been trying to get my hands on one for almost 6 months.

CPLofMARINES
June 15, 2013, 09:48 PM
Yes, I had mine sent back to CZ, and it turned out to be
The slide stop spring, they replaced it and I have not had
A problem since.


SEMPER FI

Big Dave
June 15, 2013, 10:16 PM
Any chance your grip is on the slide release? Have you shot it one handed?

Walt Sherrill
June 15, 2013, 10:25 PM
The problem you describe used to show up in a few CZs years ago, and it was (in the case of a new gun), a slide stop spring that had lost it's temper (strength), was deformed, or needed to be bent (reshaped) a bit. That's probably what's being described above by CPLofMARINES. (It's possible -- but less likely -- that you're nudging the slide stop. Double check that.)

It's unlikely to be a mag spring problem if there is no real FEEDING issues. You might try giving CZ a call. There are ways to adjust the slide stop spring yourself, to save having to ship it -- and they may be able to tell you how to do it without sending it back.

You could check the FAQ or Home Gunsmithing sections of the CZ Forum, as well -- I think there were instructions there, some years ago. Here's a link to that site, if you're unfamiliar with it: http://www.czforumsite.info/

Quick Shot xMLx
June 16, 2013, 06:39 PM
Weak mag springs? Follower issue? I have the opposite issue with my cz, hold open with ammo in the mag. I keep taking more material off the stop, little by little, it gets better but not 100% yet.
I had the same issue with my .40 P07 but only with certain brands of ammo. I called CZ and they sent me a grinded down/polished slide stop which completely fixed that problem. You should give them a call, they'll get you fixed up.

JDGray
June 16, 2013, 07:25 PM
Thanks for the heads up, I know its out of warranty but still might be worth a call.

If you enjoyed reading about "CZ SP-01 issue - anyone having problems with the slide lock?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!