Rcbs progressive problem


PDA






Josephnagy1
August 4, 2013, 09:50 PM
I am having a problem with my progressive. It is an auto index and lately it doesn't want to due a full turn. I have taken it apart and cleaned all parts. Any ideas? It seems to get hung up on the primer strips. I have loaded 1000's of rounds and it just started.

If you enjoyed reading about "Rcbs progressive problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Josephnagy1
August 4, 2013, 09:51 PM
I don't mean the actual strip. More the primer part of the primer section of the reloader

BRHbar
August 4, 2013, 09:57 PM
Will the index plate turn manually? I had just got one myself, and had trouble after set up. The plate indexed 4 or 5 times, then nothing. Long story short, the index pawl had a screw missing, that held the screw tight, that held the pawl on the spring. Try taking the index pawl off, and check to see if its loose.

higgite
August 5, 2013, 01:41 AM
Joseph, did you follow step 8 on page 5 of the instruction manual when you reassembled it? Especially the bold lettered part.
http://www.rcbs.com/downloads/instructions/Pro2000_Auto_Index_88882_Rev5-10.pdf

GW Staar
August 5, 2013, 08:31 PM
Joseph, did you follow step 8 on page 5 of the instruction manual when you reassembled it? Especially the bold lettered part.
http://www.rcbs.com/downloads/instructions/Pro2000_Auto_Index_88882_Rev5-10.pdf
That would be my guess too. If the pawl is scraping the bottom of the plate it does two things: indexes incompletely, and wears down and/or breaks the pawl. Hopefully you haven't done the second thing.....if so a call to RCBS is in order to get a new pawl coming.

Indexing should be smooth and easy with the center bolt all the way in, tight.....if tightening the bolt tightens the indexing action, you missed...and the pawl is not in one of the five holes.

The video in the following URL demonstrates:

http://www.ar15.com/forums/t_6_42/356317_How_to_set_a_RCBS_Pro_2000_shell_plate_easily__Video_.html

Josephnagy1
August 5, 2013, 10:33 PM
This is literally while I love this group. I will take apart the shell holder tomorrow and report back

Josephnagy1
August 5, 2013, 10:35 PM
I have one other question. My press is in the garage. I live in Ohio and I am seeing bits of rust. Is there anything I can use to preserve and maintain the press

GW Staar
August 6, 2013, 04:05 AM
THIS (http://www.midwayusa.com/product/541091/renaissance-wax-rust-preventative-and-gun-stock-polish-225-oz) is what they use in museums to preserve metals and you can use it about anywhere. However I lube the ram & pivots with gun oil.

Looking at your first post again, it's possible we may have targeted the wrong thing. IOW's you could have a problem with a primer or powder in the workings of the APS system under the Priming Plate....or even a broken strip advance part either the Strip Pusher pt.# 186264 or one of the little plastic detents pt. 186265. Those can be broken by trying to force a strip with a primer not pushed down. (if you remove the three screws and lift the plate make sure the 2 detents go back where they belong...and lay them in a little grease.) Page 13 of the Pro 2000 instructions show the parts and exploded view.

I have a RCBS Section on the Pro 2000 (mods and things) at AR15.com. posted on their tacked "Read First thread". Go to http://www.ar15.com/forums/t_6_42/258520_Read__First___useful_threads_for_answering_questions.html&page=1#i2526501. Maybe you can use something there.

If you enjoyed reading about "Rcbs progressive problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!