New Beretta Stovepipes


PDA






orangeninja
March 22, 2004, 12:41 AM
Hi all....we had a great time at a little THR get together here in Beautiful DFW Texas but one thing kind of left a bad taste in my mouth....my Beretta that I just got and the Preban Asian mags...do not like each other. If I were to load 15 +1 the last round will stove pipe with the bullet itself facing skyward unshot. If I put 16 rounds + 1 (it's only marked to hold 15 but will take 16) same result. HOWEVER, if I were to put ONLY 14 + 1, it worked fine. No Stovepipes, no jams. Weird. Any help on this would be greatly appreciated.

BTW the 10 Beretta mag worked fine ALSO I tried 3 different Preban Asian mags and all got the same result.

:rolleyes:

If you enjoyed reading about "New Beretta Stovepipes" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
George Hill
March 22, 2004, 01:49 AM
You have weak mag springs.
Give Wolff a call in the morning.

orangeninja
March 22, 2004, 01:51 AM
Man that would be great if true...I will certainly do so...thanks George, I owe you a drink.

George Hill
March 22, 2004, 01:56 AM
Naw... any one would have told you the same thing.
The spring has enough grunt left to push all the rounds up... but the last one. It's tired. Maybe has take a little set. Or maybe someone put the wrong springs in to begin with. Either way... a new stronger spring should clear this issue up.
If thats not it, then the lips on the mag are funky or something... but I had this on a couple mags... and new springs (under 10 bucks delivered) cured the problem.

If you enjoyed reading about "New Beretta Stovepipes" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!