Franchi Renaissance Ejection problems


PDA






RSVP2RIP
August 18, 2013, 12:41 PM
Have the above in 20 gauge and yes it does have ejectors not extractors. The top barrel will not eject fired shells. The bottom is fine. It was my fathers and I believe he did drop the barrel set onto carpet covered concrete when cleaning, that's when the problems started. It ejects A-zoom snap caps fine but not fired shells. Any brand/loading, makes no difference. I disassembled the top ejector and it is straight and clean looking. The chambers look clean and smooth and the rear of chamber doesn't look dented or dinged. I don't know what it could be. Any help?

If you enjoyed reading about "Franchi Renaissance Ejection problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
natman
August 19, 2013, 02:43 AM
Are you sure the top barrel is not cocked? Most ejector systems will only eject when the action for that barrel is uncocked.

RSVP2RIP
August 19, 2013, 08:15 AM
Fired shells will not eject out of the top barrel. It snaps like they are going to eject, it just seems like the ejector doesn't have enough grunt to pop them out. The ejector spring is strong and the snap caps get ejected to the same point.

BBBBill
August 19, 2013, 10:51 AM
Worn extractor cam? Weak extractor cam spring? (I know you said ejectors, but Franchi calls them extractors.)

RSVP2RIP
August 19, 2013, 11:40 AM
I doubt anything is worn, it has had less than 500 rounds through it. I think something must have happened when he dropped the barrels because right after is when the problems started...but stranger things have happened.

If you enjoyed reading about "Franchi Renaissance Ejection problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!