Sako 85 ejection problem


PDA






anthonyv
October 9, 2013, 08:16 PM
I recently purchased a sako 85 Blackbear in 30-06

When you eject cases or live rounds out of it they hit the windage turret of the scope and fall back into the action. Beretta Australia said the solution is higher mounts but optilock rings are very expensive.

If I rotate the scope 90 degrees counter clockwise so there is no turret on the right of the scope it works. Do you think this is the solution?

Any advice would be appreciated. Thanks. Anthony

If you enjoyed reading about "Sako 85 ejection problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
243winxb
October 9, 2013, 09:05 PM
Maybe an adjustment to the angle of the ejector? In the photo, looks like its face is on an angle?? But i can't really tell. http://i338.photobucket.com/albums/n420/joe1944usa/FirearmsReloading102/85_extractor_ejection1_2011.jpg Other have the same problem here > http://www.24hourcampfire.com/ubbthreads/ubbthreads.php/topics/6439384/1

dubbleA
October 10, 2013, 01:52 PM
I have run into the same problem with my Sako's as the scopes atop have rather large elevation turrets and the scope them self ride low. Just recently experiencing the same problem with a US Optics on a M700. The case actually turns around backwards in the action.

scottishkat
October 11, 2013, 06:10 PM
I have 2 Sako model 85's and both are medium actions 260 remington and 338 federal both have optilock low rings for 50mm objectives. My 260 has a 4.5-14x 50 Zeiss Conquest scope with Target turrets it is very close but has never hit. Try ebay or gun broker maybe you can get a used set of higher rings. The long action probably makes a difference.

Coal Dragger
October 12, 2013, 12:38 AM
I ran into that problem with my Cooper M52 in .280AI using low mounts with a Nightforce NXS 2.5-10X32. Same issue and same cause, target turrets on a long action with long cases coming out and smacking the windage turret. Dinged up the brass and more often than not bounced the empty case back into the action. Sadly even medium or high rings didn't solve the problem, so the scope had to be sent back. Glad I didn't actually tighten the rings down so I was able to exchange the scope. With a slimmer scope on top with non target turrets the problem cleared up no problem.

Unfortunately it seems like many manufacturers of scopes have gotten to the point where they put large turrets or adjustment covers on everything. It is frankly kind of annoying on a hunting rig.

6.5swede
October 21, 2013, 01:04 AM
This problem has been reported with the Sako 85 LA calibers but I haven't seen it reported with the Sako 85 SA calibers. There was a post on another forum about a year ago that reported correcting the problem by changing out the ejector spring with one produced by Gre Tan (purchased from Brownells, see pic). Two coils were cut from the Gre Tan spring to match the original length of the 85 spring.

http://i1232.photobucket.com/albums/ff366/gausi641/Swede%20and%20260%20at%20work/Sako85Ejectorspring1_zps5eac5703.jpg (http://s1232.photobucket.com/user/gausi641/media/Swede%20and%20260%20at%20work/Sako85Ejectorspring1_zps5eac5703.jpg.html)

http://i1232.photobucket.com/albums/ff366/gausi641/Swede%20and%20260%20at%20work/Sako85Ejectorspring_zpsb70ba99b.jpg (http://s1232.photobucket.com/user/gausi641/media/Swede%20and%20260%20at%20work/Sako85Ejectorspring_zpsb70ba99b.jpg.html)

If you enjoyed reading about "Sako 85 ejection problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!