PMAG problem


PDA






Archangel14
February 18, 2014, 12:40 AM
Gents:

I have a problem whereby my PMAGs (2 of them, 10 rounders) fail to lock the bolt open on my AR15 build after expending the last round. The bolt goes back into battery. I tried some other aluminum mags and everything worked fine. What do you think the issue is here? The PMAGS are brand spanking new. Any recommendations?

Thanks.

If you enjoyed reading about "PMAG problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Charlie Horse
February 18, 2014, 02:22 AM
I don't think I've ever heard those two words in the same sentence. My first thought is a bad spring.

1. Take the floorplate off of one of the mags.
2. Insert it into the rifle with the bolt closed.
3. While pushing up on the magazine spring, open the bolt and see if it locks on the follower.

I'm assuming that the mag catch hole is in the right place on the body...

justice06rr
February 18, 2014, 02:37 AM
Try the Pmags in another AR15 and see if they still fail to lock back.

Also, do all your other mags lock the bolt back on your AR except the 2 Pmag10's?

Outlaw Man
February 18, 2014, 10:31 AM
I've seen and heard of that issue on 20 round PMags. I'd try all the above to make sure it's really a magazine problem and not a rifle problem.

Archangel14
February 18, 2014, 10:45 PM
Also, do all your other mags lock the bolt back on your AR except the 2 Pmag10's?

I'm new to the AR world. All I have are the PMAG10's. I used an aluminum stock 10 rounder that came with my brother's bushmaster. It worked fine.

My first thought is a bad spring.

I thought this also, but TWO PMAGS not locking the bolt back? I think maybe it's that my upper just doesn't "mate" well with PMAGS. Is that possible?

Any other suggestions?

Archangel14
February 18, 2014, 11:11 PM
I should also note something else. I mated my upper to a New Frontier Armory lower. The upper is a budget PTAC from PSA. The two halfs mate well, except that I noticed a slight gap running between the entire length of the two. Tight fit, but when I compared the finished AR to my brother's new Bushmaster, I noticed that his two halves mate very cleanly.

Could it be that the slight gap is the cause of my locking problem?

mtrmn
February 18, 2014, 11:20 PM
I've had this same issue with 20 and 30 rd Pmags, especially 20 rounders. No problem with GI mags and green followers. All mine are older generation Pmags, but I don't know enough about them to tell which generation or to know if it really makes a difference. Once I determined it was a problem with the Pmags, I just went back to the GI mags and never looked back. I still use the Pmags, but only at the range-not for any serious endeavors. (Like I really get into serious situations where it would matter LOL)

M1key
February 18, 2014, 11:45 PM
I have a pair of ten rounders that will lock back in a few of my ARs when hand-cycling, but fail to consistently do it live firing on the last round. I figure I will relegate them to range mag status. Or sell them...

M

Archangel14
February 19, 2014, 12:46 AM
I have a pair of ten rounders that will lock back in a few of my ARs when hand-cycling, but fail to consistently do it live firing on the last round.

That's my exact situation! When hand cycling, no problem, they lock. But they almost always fail on the last round.

No problem with GI mags and green followers.

Wonderful to know. I've never heard of these magazines (I know little of the AR world). Can you be more specific in what other mags are preferred?

M1key
February 19, 2014, 01:59 AM
Older GI mags had a green follower. They are still made and Bravo Company sells them.

I have had the same problem on occasion with Colt 8 rounders. Try some other GI aluminum mags, if you are able. I also like the 20 round GIs.

M

mtrmn
February 19, 2014, 09:24 AM
Most "GI" mags are aluminum 20 or 30 rounders. They may sometimes be steel, but never plastic that I know of. All my 30 rounders have the green followers like M1key pictured. 20 rounders take a different follower, and may not be green.
Cope's distributing, Widener's, Aim Surplus, and pretty much all online sellers usually have them, although I think the green follower may be getting scarce now. Most current ones made by D&H.
If you are limited to 10 rounds, GI mags are not for you. And as long as your Pmags feed AMMO well, they are plenty good enough for range use-the lack of last round hold-open is a mere inconvenience.

Archangel14
February 19, 2014, 10:44 AM
And as long as your Pmags feed AMMO well, they are plenty good enough for range use-the lack of last round hold-open is a mere inconvenience.

Thanks. Yes, I agree your with. It's an inconvenience, at best. But I'd just like the entire platform to work as intended.

Do you know who provides the new Bushmaster with their mags? They worked really well with my rifle.

MrTuffPaws
April 23, 2014, 01:31 AM
I have the same problem with a new lower that I am building. Gen3 Pmags won't catch the bolt catch 1/10th of the time. They are a bit lose in the mag well, so if you apply some torq so the mag is forward while seating it won't pick up the catch. I have tried colt and two green follower generic aluminum mags and they work fine.

I have even replaced the bolt catch thinking the old one might be out of spec. No go. The only solution that I have found was some guy using a ground down 9mm bolt catch. He ground it down just long enough to function without hitting the rounds in the mag.

Looking for Knowledge
April 27, 2014, 12:05 PM
I thought this also, but TWO PMAGS not locking the bolt back? I think maybe it's that my upper just doesn't "mate" well with PMAGS. Is that possible?

The bolt catch is part of the lower. I have never seen an upper effect the catches' performance. Feeding issues, yes. Try applying pressure up on the bottom of your magazine and see if that helps.

K0ZZZ
April 27, 2014, 10:40 PM
The 10 round PMAGs I have had this issue. On the back of the follower, there's a small ridge that would catch on the back of the magazine. Dremeled that off lightly, and no more problem.

Quentin
September 13, 2014, 08:09 PM
I just bought 3 Magpul Gen3 (manufacture date 12/2013) 10-round magazines today that wouldn't hold back the bolt when hand cycling in three ARs. These ARs have no problem with other PMAGs, including Gen3 20 and 30 rounders.

I found that when the follower engages the bolt catch it tilts then catches on the rear of the magazine body instead of lifting the bolt catch. Once I saw what was happening I could hold any of the magazines in my hand and tilt/lock the follower just by pressing down on the follower with a flat blade screwdriver (placing the screwdriver blade where the bolt catch engages).

Then I disassembled each magazine and using the screwdriver scraped and smoothed a sharp ridge at the top of the magazine body that was snagging the follower. Now all three magazines work properly in the three ARs.

I was going to make a new thread but found this recent one so it makes sense to update it instead. I notice that Chad (K0ZZZ) solved the problem by smoothing out the rear of the follower while I smoothed the inside of the magazine body. Either way seems to work and I bet over time normal wear would solve the problem.

taliv
September 13, 2014, 09:12 PM
you guys should send an email to magpul

rbernie
September 13, 2014, 09:33 PM
I should also note something else. I mated my upper to a New Frontier Armory lower. I can't help but believe that this is the issue, assuming that you're talking about the polymer lower. They're not BAD lowers but they are also not the tightest spec.

Quentin
September 13, 2014, 09:54 PM
you guys should send an email to magpul

Taliv, I did send an email to Magpul which was a slightly edited copy&paste of my post above. No doubt they're already aware of the issue but just in case I wanted to let them know. It may already be corrected in magazines made after 12/2013. I'll update the thread when I get a response from Magpul.

Quentin
October 4, 2014, 04:56 PM
After two emails I did get a response from Magpul about the issue...


From : Magpul Tech Support <techsupport@magpul.com>
Subject: RE: Magazine follower problem in 10-rd Gen 3 PMAG

Thank you for contacting us. We did have some PMAG10 go out that did have some flash in that spot. What you did is the quick fix that we had for the mags. If you have any further problems feel free to contact us glad that you got them working.

Daniel Hunter, Tech Support Specialist

If you enjoyed reading about "PMAG problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!