Msbrg 590 A1: pump catches Please Help


PDA






Huntolive
March 7, 2014, 01:51 PM
I have a 18.5" brl practically new 590 A1. (I think 5 plus 1)
I am second owner. I t looks great, but when I tested it to see how it would pump rapidly, the pump got stiffer instead of smoother.
When fully open, the something seems to be catching up. you can force the pump forward with a firm pump, but it dosn't feel right.
This does Not happen every time. It also seems that the little shelf that comes down to hold the next shell (shell carriage?) comes down a bit far when it sticks.
I admit I was dry firing when I was fast pumping and pulling the trigger to test the pump speed/cycling. Then I loaded it, and the same effect continued.
According to first owner, the gun only had 10 rounds thorugh it, and by the looks of it, I believe that.

How do I smooth it up?

Thanks!

If you enjoyed reading about "Msbrg 590 A1: pump catches Please Help" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
1KPerDay
March 7, 2014, 02:25 PM
Take it apart (not the trigger group). It's very straightforward. Look for burrs on the lifter/shell carriage, action bars, bolt, bolt slide, shell stop/interrupter, locking block thing, etc.

Have you actually shot it yet? Is it catching/jamming when cycling dummy/live rounds or when empty?

Huntolive
March 7, 2014, 02:27 PM
Thanks,
It is catching primarily when empty, but also w/ live rounds. You can push through the jam with a bit of extra force, but that dosn't seem right. How do I take it apart? are there any small parts to mix up re-assembling?

1KPerDay
March 7, 2014, 02:34 PM
http://youtu.be/oKbWcPdTRBI
I found this video helpful. Your 590 barrel nut/mag cap is different but self-explanatory. If you have a heat shield installed or sidesaddle, let us know; they can complicate disassembly. Otherwise it should be identical to the video above.

don't take the trigger group apart. Everything else is pretty straightforward. Also download the manual and read it. :)

http://www.mossberg.com/manuals/500_835_590_535_en.pdf

Clean it, apply some oil, check the action bars and all other parts for burrs/binding, lighly stone if you find any burrs. Be careful messing with the shell stop and interrupter... these parts are best left alone if you don't know what you're doing.

You might be able to see what's going on if you slowly pump the slide after removing the trigger group. Take a close look and see if you can identify when/where the binding occurs.

Huntolive
March 8, 2014, 10:12 AM
Thanks, and best of luck!

ugaarguy
March 8, 2014, 10:56 AM
How do I take it apart? are there any small parts to mix up re-assembling?
You might want to look at the stickies at the top of each forum. Evan Price wrote this excellent guide with great pictures - http://www.thehighroad.org/showthread.php?t=423402.

rcmodel
March 8, 2014, 11:07 AM
It's probably dry as a bone.
Or still full of packing oil, which was not intended to be lubricant.

A little grease or oil in all the right places will go far!!!

Rc

Huntolive
March 13, 2014, 01:31 PM
Thanks guys!

AI&P Tactical
March 13, 2014, 04:34 PM
It can also be as simple as the forend is not centered on the forend tube assembly and rubbing the barrel. Look at that as rack the forend back and see if it is rubbing.

If you enjoyed reading about "Msbrg 590 A1: pump catches Please Help" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!