1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Chronograph trouble

Discussion in 'Shooting Gear and Storage' started by Donny, Jan 12, 2013.

  1. Donny

    Donny New Member

    Sep 22, 2006
    I own a pro-chrono chronograph I bought from Cabelas several years ago. Recently its been acting screwy. Its been giving me the wierdest velocities. Black powder pistols that I know should be launching balls at velocities between 400 to 600 feet per second are getting measurments if 150 fps or less. I changed the battery and cleaned the windows covering the sensors thinking that may be the issue. I used it again today with the same pistols and powder and got really strange results. One shot would register at 98 fps and the next would register at over 2500 fps. Any body have a clue about what could be wrong with this machine?


  2. esheato

    esheato Senior Member

    Apr 8, 2003
    How close are the sensors to your muzzle? I've had wildly inaccurate readings when the sensors were too close.
  3. Reloadron
    • Contributing Member

    Reloadron Mentor

    Jul 6, 2012
    Cleveland, Ohio USA
    If all things are the same as previous use such as was mentioned distance between muzzle and sensors and ambient lighting conditions my guess would be that the internal clock circuit is failing. The chronograph uses an internal clock running at what should be a fixed frequency. The first sensor opens a gate allowing the clock pulses to be counted and the second sensor closes the gate stopping the clock pulse count. Then math is applied to derive a velocity based on distance between the sensors.

    When things like this happen the best course of action is usually to call the manufacturer and see if they will take it back for repairs. This assumes that all your user variables are unchanged. Sounds to me like the electronics have just become erratic.

  4. Jaag

    Jaag New Member

    Jul 24, 2012
    NW WI
    I had a similar experience with mine, sometimes it was fine and sometimes it wasn't. I suspect Reloadron has it nailed.
    I have a friend who had another type and was talking about how touchy his was. He rarely used the skyscreens on his because it seldom worked good that way. Next time out, I didn't use the skyscreens and the thing seemed to work fine. Thought it was odd but it was giving the same results it did in the beginning so I kept using it.
    I used it with and without until finally it didn't matter and one day it just wouldn't work anymore. I got about 8 years out of it so I just bought another one. Pretty sure you can send them back to the factory and have the two modules replaced.

Share This Page