1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

lyman 1200 DPS 3 problems

Discussion in 'Handloading and Reloading' started by jonjon1885, Mar 15, 2008.

  1. jonjon1885

    jonjon1885 Well-Known Member

    I'm sure some of you guys have had some experience with this great gadget.
    but i'm having problems with mine. today i let it sit turned on for about 6hours beofre i got back to reloading (read as forgot to turn it off while working) then i when back to loading and it worked fine for about 5-6 drops and then the key pad locked up and stopped dropping powder.

    now i pulled out the power cord and let it sit for a few hours. now when i plug it in and ty to turn it on it just has a constant beep and the screen is all black (looks like all 8's) and wont go into normal starting.

    with all that said what do you guys think?

    oh and i got this new for Christmas form the wife so receipt or proof of purchase.
  2. steve4102

    steve4102 Well-Known Member

    Unplugging the unit is the first step, that didn't work. Next is to make sure that there is no grains of "Rat turd" extruded powder between the scale base and the housing. The clearance between these two is just the right size for some rat turd powders to get stuck. Next is to make sure that none of the buttons are stuck down. And last call Lyman, they will be more than happy to help.

    I have an older model that is well past the one year warranty. Out of the blue my keyboard gave out. I called Lyman and they told me to send it in. Four years old and they replaced the keyboard for free, only took about 2 1/2 weeks.
  3. jonjon1885

    jonjon1885 Well-Known Member


    thank you for your advise but after letting it sit a little longer it just started to work perhaps it "just needed a rest" but who knows. i love the damn thing and got scared.
  4. mdgtrades

    mdgtrades New Member


    I finally 'pulled the trigger' on purchase of a Lyman 1200 DPS 3. I set it up and let it warm up for 24 hours. Tested the scale, compared to my beam, and began reloading .45ACP. Once I got comfortable with the manual dumps, I turned on Auto mode and began dumping charges.

    At a count of 45, just 5 short of a full rack, the thing stuck on and began dumping powder into the tray. Before it overflowed I unplugged the power cord to stop the auger. When I plugged it back in, the motor started running again dumping more powder; the tray must have had 50 gr by then. So I unplugged it again.

    I emptied the powder turned it back on and hit all the clear, reset and cal buttons multiple times. It appeared to start working again so I finished the final 5 charges [checking against the beam scale]. During this time, it shut off again. I turned it back on, it worked for awhile, and then it shut itself off again.

    So I'm going to take it back and don't know if I want to try another one or just continue to use a Lyman 55 [which I do trust]. I'm torn because [being a gadget guy] I really like the DPS 3 when it's working right.
  5. Afy

    Afy Well-Known Member

    I have had powder stuck once. But then thank god that was the only issue I had with it.
    I love my DPS 3.
  6. ranger351w

    ranger351w Active Member

    1200 dps 3

    Just got mine and right out of the box I saw MADE IN CHINA!:fire: Strike one

    I will set it up in a week or so. Hope it is better than where it is made.
  7. Afy

    Afy Well-Known Member

    The other thing I have found is that putting the power cord through a small line cleaning magnet really makes it work better. Fewer Cal 0 requirements etc.
  8. TooTaxed

    TooTaxed Well-Known Member

    One caution on these fine measures...after a few dropped charges the scale will begin to drift slightly.:eek:

    To keep the charges uniform, all you need to do is press the "cal-zero" button every 5 charges. Lyman notes this as the very last item on the "Suggestions/Tips" portion of the manual.;)

    Lyman also now has a combination scale pan and funnel...a very useful accessory! Got mine from Midway...

Share This Page