Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AR15 Build Issue

Discussion in 'Rifle Country' started by strange246, Jan 23, 2013.

Thread Status:
Not open for further replies.
  1. strange246

    strange246 Member

    Joined:
    Sep 1, 2005
    Messages:
    124
    Location:
    Merrimack, NH
    Built my AR about 2 months ago but just got a chance to shoot it, Del-Ton Dissapator upper, A2 stocked LW15 lower, magpul mag, 2 different ammo's, the first round feeds and fires fine, 2nd round gets loaded but the bolt never traveled far enough back to reset the hammer, I assume the issue is to do with the gas system being rifle length with only the 16" barrel, would a lighter buffer spring help? Perhaps a carbine length spring and buffer in the A2 buffer tube?

    Thanks
     
  2. MachIVshooter

    MachIVshooter Member

    Joined:
    Aug 11, 2005
    Messages:
    14,375
    Location:
    Elbert County, CO
    Not possible.

    There's an issue with your secondary sear; Perhaps the spring is not installed correctly?
     
  3. strange246

    strange246 Member

    Joined:
    Sep 1, 2005
    Messages:
    124
    Location:
    Merrimack, NH
    Hmm I'll check, this lower I bought assembled, but I suppose its not impossible to be built wrong...
     
  4. GI_Jared

    GI_Jared Member

    Joined:
    Dec 8, 2011
    Messages:
    279
    please post some pics of the build, this will help in the diagnosis.
     
  5. strange246

    strange246 Member

    Joined:
    Sep 1, 2005
    Messages:
    124
    Location:
    Merrimack, NH
    Only pic I have of if right now...
    [​IMG]
     
  6. GI_Jared

    GI_Jared Member

    Joined:
    Dec 8, 2011
    Messages:
    279
    need to see inside the lower receiver, where the trigger assembly is.
     
  7. strange246

    strange246 Member

    Joined:
    Sep 1, 2005
    Messages:
    124
    Location:
    Merrimack, NH
    Ah gotcha, I'll post some in the morning, I cant get to it right now...
     
  8. Jackal

    Jackal Member

    Joined:
    Mar 9, 2006
    Messages:
    4,466
    Location:
    Northwest Washington
    Your short cycling. Make sure your bolt carrier is not rubbing on an out of spec buffer tube, I had this happen once. I would retract the bolt by hand and it would stay in the buffer tube:what::banghead:. Also, check to see if there isnt a bur or blockage where the barrel mates with the gas block/check for a good seal/alignment.
     
  9. Infidel4life11

    Infidel4life11 Member

    Joined:
    Nov 28, 2011
    Messages:
    621
    Location:
    Where the Army puts me
    I would say your trigger group also. Sound like your hammer isn't being caught.
     
  10. briansmithwins

    briansmithwins Member

    Joined:
    Aug 1, 2005
    Messages:
    4,063
    Yeah, if the BCG is opening enough for the fired case to be ejected, much less the next round loaded, the hammer is being cocked.

    I agree that the problem is most likely the hammer following the BCG down.

    BSW
     
  11. Ramone

    Ramone Member

    Joined:
    Sep 26, 2008
    Messages:
    725
    Location:
    Tidewater VA
    my best guess:

    Disconnector spring upside down.

    It's the tiny spring that sits in the trigger under the disconnector- one end of the spring is larger- that one goes 'down' (into the trigger first) so it stays in place.

    [​IMG]
     
Thread Status:
Not open for further replies.

Share This Page