Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Automatic Primer System on RL550

Discussion in 'Handloading and Reloading' started by Chacon, Mar 15, 2008.

Thread Status:
Not open for further replies.
  1. Chacon

    Chacon Member

    Joined:
    Feb 1, 2008
    Messages:
    6
    I am having problems with my Automatic Primer System. I just bought the machine but it was used. Not sure how it supposed to operate so i don't know what wrong with it. As i look into where the primer cup meets the primer magazine there is a huge gap I can't see any primers. The primer magazine is inserted correctly i looked several times. I believe the tab is supposed to face away the from the shell. Any help would be appreciated. I can take some photos if they are needed.
     
  2. Uncle Chan

    Uncle Chan Member

    Joined:
    Nov 3, 2007
    Messages:
    326
    Photos would be VERY helpful.
     
  3. neal7250

    neal7250 Member

    Joined:
    Jan 2, 2008
    Messages:
    336
    Location:
    Upstate South Carolina
    I would call Dillon on Monday morning. They will get you up and running. Kinda hard to help with the info you provided.

    http://www.dillonprecision.com/
     
  4. DILLONHELP

    DILLONHELP Member

    Joined:
    Jun 7, 2006
    Messages:
    70
    Location:
    Arizona
    It sounds like either the aluminum primer magazine tube is missing or not inserted correctly. If present, there is a ridge on the plastic tip at the bottom of the magazine tube. When inserting the tube into the shield, you need to rotate it after it bottoms out, so that the ridge finds the groove it slips into. Then the tube drops down another 1/4".
     
Thread Status:
Not open for further replies.

Share This Page