Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bersa 97

Discussion in 'Handguns: Autoloaders' started by presspuller, Nov 19, 2011.

Thread Status:
Not open for further replies.
  1. presspuller

    presspuller Member

    Joined:
    Jan 17, 2007
    Messages:
    502
    Location:
    NC
    I have a Bersa 97 that appears to be in decent condition but it does a weird thing. If one releases the safety, you still can't pull the trigger till the pistol is tipped 90 degrees to the left and then the trigger can be pulled to fire. Obviously there is something on the inside catching but I know not what. Any ideas?
    Also how does this thing come apart, I don't have a manual.
    Thanks.
     
  2. DanTheFarmer

    DanTheFarmer Member

    Joined:
    Sep 24, 2010
    Messages:
    379
    Location:
    New Hampshire
    Good Evening,

    I've got a couple of leads for you.

    1. Try asking your questions over at www.bersachat.com. They're good people and they have various sub-forums where you can (hopefully) find someone who knows about your out of production model.

    2. I've got a current production model BT380 that a similar exterior appearance so perhaps the internals are similar as well. Try removing the right grip panel. I had problems with a magazine disconnect safety spring on my pistol. When I removed the panel it was obvious even to this non-mechanically inclined person what the problem was and the fix was equally obvious. Perhaps you will luck out as well and it isn't much of a bother even if it doesn't work out.

    Good Luck,

    Dan
     
  3. NG VI

    NG VI Member

    Joined:
    Dec 12, 2007
    Messages:
    4,884
    Location:
    Maine
    My CZ 97 did that once, there was a screw inside the frame, behind the trigger guard, that needed tightening. After tightening it everything was fine. Check for something similiar in yours.
     
  4. presspuller

    presspuller Member

    Joined:
    Jan 17, 2007
    Messages:
    502
    Location:
    NC
    Thanks guys, it was the mag safety. Got it all fixed and its good to go.
     
Thread Status:
Not open for further replies.

Share This Page