Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Grip technique problem.

Discussion in 'Handguns: Autoloaders' started by Thrash1982, Oct 4, 2005.

Thread Status:
Not open for further replies.
  1. Thrash1982

    Thrash1982 Member

    Joined:
    Apr 25, 2003
    Messages:
    412
    Location:
    Indiana
    This past Saturday I went to the range to shoot for the second time my new (to me) SIG 226 in 9mm. I kept having a problem with limpwristing the gun. Not enough to make it malfunction but enough so that it wouldn't lock open on an empty mag. My friend I was shooting with had no problems with it with either of my mags. I've never had this problem with any other 9mm pistol including a different SIG 226.

    With a one handed offhand grip it would lock back for me but with a two handed weaver grip I couldn't get it to do it. Seems I'm having trouble locking my wrist when using a two handed grip. Can anyone offer any suggestions?

    Odd thing is, the first time I shot it I didn't have this trouble at all.
     
  2. jaybar

    jaybar Member

    Joined:
    Jan 5, 2004
    Messages:
    186
    Location:
    Northeast Ohio
    Faulty grip???

    Any possibility that the thumb of the second hand is interfering with the movement of the slide lock lever???
     
  3. Thrash1982

    Thrash1982 Member

    Joined:
    Apr 25, 2003
    Messages:
    412
    Location:
    Indiana
    I took a look at my grip and it looks like that I may be holding down the slide stop with my right thumb. The SIGs slide stop is in a much different place than I'm used to. I'll have to try a different grip next time I shoot it.
     
  4. f4t9r

    f4t9r Member

    Joined:
    May 27, 2005
    Messages:
    2,670
    Sounds like that is the problem
    very rare to have any problems with a sig have had a P226 for years and my daughter with her light grip has never had a prob
     
  5. Thrash1982

    Thrash1982 Member

    Joined:
    Apr 25, 2003
    Messages:
    412
    Location:
    Indiana
    yeah, that's what was confusing me cause I've never had that problem with any other 9mm. Hopefully I'll be able to get out and shoot in a couple weeks and see if that was the problem. Thanks guys
     
Thread Status:
Not open for further replies.

Share This Page