Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help. Tumbler Broke.

Discussion in 'Handloading and Reloading' started by Wilburt, Nov 6, 2009.

Thread Status:
Not open for further replies.
  1. Wilburt

    Wilburt Member

    Joined:
    Jan 3, 2008
    Messages:
    319
    Location:
    North Carolina
    Well, I have a Lyman 2500. It has always worked fine. I just tumbled some brass 2 days ago. I have not noticed anything wrong. No slowing of motor, wierd sounds, etc. All of a suddon, when i plug it in, nothing happens. I've tried several differant outlets.

    Nothing appears to be wrong with the cord or plug. Any ideas?
     
  2. jjohnson

    jjohnson Member

    Joined:
    Oct 7, 2005
    Messages:
    1,181
    Location:
    Rochester, Minnesoviet
    Does it hum?

    Your motor might be burnt out. That's what's happened to 2 of mine in the last few years. :banghead:

    Both of mine would hum fairly loudly, and I could spin the fan blades a couple of times with a screwdriver (NOT while it's plugged in) and get them to start again, then they'd go awhile and stop. Time to call Lyman to see if you can get a warranty replacement.
     
  3. Drail

    Drail Member

    Joined:
    Jan 17, 2008
    Messages:
    5,378
    Contact Lyman. If they cannot help you'll have to run some continuity tests to find the problem. Electrical joints on something like a vibratory tumbler are prone to coming loose. The motor may have just given up. If your tumbler has an inline on/off switch check that first.
     
  4. rfwobbly

    rfwobbly Member

    Joined:
    Nov 14, 2008
    Messages:
    3,944
    Location:
    Cornelia, GA
    My small Dillon did the same thing. It's a burned out motor. Call Lyman and talk to them.
     
  5. ranger335v

    ranger335v Member

    Joined:
    Dec 3, 2006
    Messages:
    3,797
    "Any ideas?"

    Yeah, a sudden stoppage is frequently from a power wire being broken by the constant viberation.

    Take off the bottom cover (may be difficult but it WILL come off!) and check the connections between the power cord and motor. If one is loose, solder them back or use small wire nuts to recconnect them.

    And put a couple of drops of a good, non-gumming light oil (NOT WD-40!) on both of the bronze sleeve bearings while you're in there. Many tumbler "failures" are simply from the factory oil drying out, gummin up and seizing the motor shaft.

    Suggest Automatic Transmission Fluid (Walmart's auto lube department) is a great low drying, non-gumming oil. I use it excluessivly for guns, fishing reels and small electic motors. Cheap, works very well.
     
  6. ranger335v

    ranger335v Member

    Joined:
    Dec 3, 2006
    Messages:
    3,797
    "Any ideas?"

    Yeah, a sudden stoppage is frequently from a power wire being broken by the constant viberation.

    Take off the bottom cover (may be difficult but it WILL come off!) and check the connections between the power cord and motor. If one is loose, solder them back or use small wire nuts to recconnect them.

    And put a couple of drops of a good, non-gumming light oil (NOT WD-40!) on both of the bronze sleeve bearings while you're in there. Many tumbler "failures" are simply from the factory oil drying out, gummin up and seizing the motor shaft.

    Suggest Automatic Transmission Fluid (Walmart's auto lube department) as a great low drying, non-gumming oil. I use it excluessivly for guns, fishing reels and small electic motors. Cheap, works very well.
     
  7. Wilburt

    Wilburt Member

    Joined:
    Jan 3, 2008
    Messages:
    319
    Location:
    North Carolina
    Thanks. I'll give lyman a call and most likly take it apart and look for a wire off. I'll let you know any progress. Oh and it doesn't hum. It doesn't do anything.
     
  8. rondog

    rondog Member

    Joined:
    Jun 29, 2007
    Messages:
    6,824
    Location:
    Commurado
    Is there a switch in the power cord? Sometimes those will crap out, and replacing the switch fixes the problem.
     
  9. Encoreman

    Encoreman Member

    Joined:
    Jul 24, 2006
    Messages:
    422
    Okay don't shoot me for saying this, but do you know the receptacle you are plugged into is live? Check it with a tester or light or plug the tumbler into another receptacle. Let us know what the problem was. Mac
     
  10. Wilburt

    Wilburt Member

    Joined:
    Jan 3, 2008
    Messages:
    319
    Location:
    North Carolina
    The is no in-line switch. Also, yes I have tested the outlet. I've also plugged it into 3 differant "Working" outlets (wishful thinking). Not a bad suggestion though. At times that might have been the problem;).

    I called Lyman 1 minute after they closed for the week. :banghead: Will try them on monday, if I don't get too curious and break it while trying to take it apart and fix it myself. My wife says I should definitly wait with how I fix things :D
     
  11. Ret.CWO

    Ret.CWO Member

    Joined:
    Oct 4, 2009
    Messages:
    152
    Location:
    So. Florida & Western N.C.
    Ranger335V:banghead: is correct one of the power wires may be broken. I've had to sodder one or both about five times over the years. The constant vibrating takes a toll on the connections.
     
  12. offthepaper

    offthepaper Member

    Joined:
    Dec 5, 2005
    Messages:
    1,439
    When my motor went up on my tumbler, the motor just started sounding a bit different (from slowing down) and just didn't agitate the media with the same force. It was an obvoius loss of power to the motor over a short period of time.
    But what was described here, the sudden loss of any motor action at all, no grind, no humm, nokiss my ...., or anything would certainly point me in the direction to chec to make sure the motor is getting voltage. As stated, the vibration can easily fracture a solder joint, break a wire, make a retention screw lug back out from it's threads. Just my 2 cents, but I would try these before sending it back to Lyman. But if you do check these and all check out. Use your warranty with the mfg.
     
  13. Otto

    Otto Member

    Joined:
    May 14, 2007
    Messages:
    1,394
    Location:
    Lone Star State
    How old is the unit? Under warranty?
    If not, Lyman sells replacement motors for $55.
     
  14. Ret.CWO

    Ret.CWO Member

    Joined:
    Oct 4, 2009
    Messages:
    152
    Location:
    So. Florida & Western N.C.
    Ranger335V:banghead: is correct one of the power wires may be broken. I've had to sodder one or both about five times over the years. The constant vibrating takes a toll on the connections.
     
  15. Wilburt

    Wilburt Member

    Joined:
    Jan 3, 2008
    Messages:
    319
    Location:
    North Carolina
    It's probally just over 2 years old or just under. I'll try to look at the conections today.
     
  16. Peter M. Eick

    Peter M. Eick Member

    Joined:
    Dec 28, 2002
    Messages:
    5,035
    Location:
    Houston, TX
    I found that on my 1292 tumbler the wire broke to the motor. A couple of minutes with a soldering iron fixed it.

    I got a Thumblers Tumbler as a backup, actually it is now the primary.
     
  17. Roccobro

    Roccobro Member

    Joined:
    Apr 6, 2006
    Messages:
    1,506
    Location:
    San Berdoo, CA
    I bought a whole new 2500 instead of a replacement motor. $70 shipped on sale.

    Got spare parts now! :D

    Justin
     
  18. Wilburt

    Wilburt Member

    Joined:
    Jan 3, 2008
    Messages:
    319
    Location:
    North Carolina
    Alright. Curiousity got the best of me. I took it apart as far as I could. The problem is that it is a sealed unit. Meaning everthing it hotglued. To get to the motor I would have to reheat the glue to get the top off then re-glue it back when I'm done. I tried prying a little to see what I could see and all the wires are hot glued in place.

    Not sure, guess I'll call on monday but it's no longer under warrenty being 2 years old.
     
  19. Roccobro

    Roccobro Member

    Joined:
    Apr 6, 2006
    Messages:
    1,506
    Location:
    San Berdoo, CA
    Being 2 years old, it might be covered under a bad batch of motors about that time. About the time I got mine in fact. I bought a new one as I felt I had got my moneys worth from the unit.

    But if this new one fails at about the same amount of use, then I'll know more of what to expect.

    Justin
     
  20. Roccobro

    Roccobro Member

    Joined:
    Apr 6, 2006
    Messages:
    1,506
    Location:
    San Berdoo, CA
    Woops...

    Double tap?
     
  21. Otto

    Otto Member

    Joined:
    May 14, 2007
    Messages:
    1,394
    Location:
    Lone Star State
    Let's us know what Lyman says.
    Personally, I wouldn't put another dime in that tumbler.
    If it was new and only lasted 2 years I would cut my loses.
    Bite the bullet and buy a Thumlers UV-18...metal base, double-wall bowl and a 3.5 inch Fasco motor.
     
  22. Wilburt

    Wilburt Member

    Joined:
    Jan 3, 2008
    Messages:
    319
    Location:
    North Carolina
    Well I called today. The lady said it was no longer under warranty but if I sent in just the base, they would look it over and try to repair it for $$? I asked how much it generally cost for this type of thing and she said not too much and if it looked too bad they would just advise me to buy a new base for $55.

    So I would pay to ship it there, get fixed, and be shipped back... I think I will take me chances on trying to fix it myself. I read several stories of people having their lyman last 20 years. I've also read several saying they only lasted 2 years like mine. I guess it's a bit of luck and wheather you overload it or not.

    In the mean time I did alot of research on tumblers. Dillion was recomended by alot but the same about 2 years and 15 years. So I was torn between the Thumbler UV-18 Industial and the Berry's 400 (Grafs and Cabela's same thing for cheaper). Both had good stuff said about them and not alot of bad (none on the UV-18 Ind I could find). At cabela's its $45 and the UV-18 Ind is $260. Tim the tool man taylor got the best of me and I bought the UV-18 Ind. Thinking back I could buy 5 of the other. Oh well. Next time around if I need too.
     
  23. Maj Dad

    Maj Dad Member

    Joined:
    Dec 1, 2005
    Messages:
    1,619
    Location:
    Carolina Low Country
    Wilburt,
    Just went through all this with my Dillon CV-500; got a new motor from Dillon for $39.95 & sh. (Midway wouldn't sell me one - 2 of theirs bit the dust). Stone simple change out of whole motor/cord unit and it's vibrating like a Jack Russel's tail with a rabbit in sight. On the other hand, I have a Lortone barrel tumbler (similar to Thumbler's) that I bought at a yard sale in the early 80's, and it was old then. It's still running, and I keep it around because it is so reliable. I have polished stones in it, too (for which it was designed: running for days at a time) and it just keeps going, and going, and... next I will build one on a 5 gallon bucket and some big rollers, or get a CEMENT MIXER! and polish thousands and thousands at a time... ;)
     
  24. Otto

    Otto Member

    Joined:
    May 14, 2007
    Messages:
    1,394
    Location:
    Lone Star State
    Thumler's industrial UV-18 doesn't clean brass any better than their standard UV-18.
    The industrial UV-18 is designed for wet rock polishing. The standard UV-18 is designed for brass. I had a lengthy discussion with the owner of Thumler's Tumbler about the industrial model. and for brass he strongly recommended buying the standard UV-18 instead. Additionally, you can find a much better price than $260 for the Industrial...if that's what you're determined to buy.
     
    Last edited: Nov 10, 2009
  25. Wilburt

    Wilburt Member

    Joined:
    Jan 3, 2008
    Messages:
    319
    Location:
    North Carolina
    Hun..... Can't argue with that. I wonder why so many people buy the Industial version then?
     
Thread Status:
Not open for further replies.

Share This Page