1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Powder measure

Discussion in 'Handloading and Reloading' started by Sinsaba, Feb 2, 2008.

Thread Status:
Not open for further replies.
  1. Sinsaba

    Sinsaba Member

    Apr 14, 2005
    Northern VA
    I'm having a problem with my Lee press. It is a 4 hole turrent press. I can't remember when it started or what I may have done to cause the problem so it is really bugging me. I know what the problem is but not what is causing it. First the information on the setup. Since the proble seems to be with all calibers (rifle as well as pistol) and the problem seems to be with the powder handeling here is the powder handeling information:

    Auto Disk Powder Measure
    Pro Auto Disk Update Kit
    Swivel Adaper
    Auto Disk riser

    The problem is this. When I'm charging the case, the case doesn't seem to be pushing the tube all of the way up. This causes the auto disk to come forward but not all of the way. It somes forward enough for most of the charge to drop into the case but a) is not consistant, b) if it is a big charge more of the hole doesn't meet up with the tube so less of the charge gets dropped.

    If anybody has any ideas I'll take any suggestions.

  2. Eric F

    Eric F Member

    Jul 23, 2007
    is the swivle upside down? Or if the other kind is it screwed in all the way? Is the die adjusted properly? Is your chain/spring binding do you have them in the right hole? Just some thoughts right off my heas with out seeing one in person.
  3. shootinxd

    shootinxd Member

    Dec 31, 2007
    Try taking everthing apart and follow instructions to the letter.I have the same set up and works great.Lee instructions are not the best but if all else has failed then its time to start over.
  4. KFDiesel

    KFDiesel Member

    Aug 9, 2007
    It might be you. I had the same problem with my Lee Auto Disc powder measure untill I realized I was placing the disk on the powder measure wrong. Hasnt happened snce. good luck.
  5. stubbicatt

    stubbicatt Member

    Aug 23, 2007
    Try screwing the die into the press a little further to gain additional mechanical advantage.
  6. jfh

    jfh Member

    Aug 28, 2003
    Maple Plain, MN
    There seems to be three reasons for the Lee measures not working correctly with the spring return setup on the turret presses.

    1. The PTED or the RCD (Powder-through expanding die or the Rifle Charging Die) is not set up properly--e.g., die is not set 'deep enough' to fully actuate the arm when the case is brought up into it.

    2. Related to this is the proper combination of drop tubes and / or extensions for the actuator to be long enough to allow proper die adjustment, and

    3. The disk / charge bar may in fact be hanging up on the hopper; related to that is the off chance that you do NOT have the actuator lever in the proper slot in the disk / bar.

    I am assuming you do have the adapter and riser screwed down snugly--you haven't forgotten to tighten the swivel adapter, have you?

    Problem one is solved by setting up your dies properly. Personally, I would start with re-setting the sizer-decapper die, and then keying the PTED die off that adjustment.

    Problem two still has me confused as to why it happens--but I found that, for my Lee measures set up with the spring-return lever, I needed to use the long drop tube that passes through the swivel and through the riser. What comes with which version / update / upgrade, I don't remember. I called Lee support at one time about this, and I remember that there were at least three 'packages' of drop tubes and extenders that can be mis-combined, I think. At any rate, I solved my problems with the long drop tube.

    The third problem is the maddening one, and it is a genuine malfunction: The disk / bar does not return properly (under spring tension) to line up with the hopper opening, and therefore does not receive a full charge.

    If this is what is happening, then first start by confirming you have the actuator lever in the proper slot. If it is, then double-check that you do not have the hopper screwed down to tightly for the disk / hopper to slide smoothly into place. Related to this problem can be a weak / worn return spring--which I think is generally unlikely. Finally, the hangup can be caused by worn components--the hopper (or wiper, in the pro kit) is worn, or roughened, or the disk / bar is.

    A few us have discussed problem three when it happens--and never have been able to tie 'hanging up' to any one thing consistently. I did find the problem occurred in all the ways I identified in the preceding paragraph, but typically the hangup occurred when I overtightened the hopper screw-down nuts.

    From what you describe here, Sinsaba, I'd start by

    1. confirming you have it properly assembled (the lever in the proper disk);

    2. the screws are not too tight, and

    3. The wiper/hopper and the disk / bar are not binding / worn.

    If those check out OK, then go to

    1. re-doing your die setup, and

    2. installing the long drop tube.

    Jim H.
Thread Status:
Not open for further replies.

Share This Page