Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ruger MK1 Help.

Discussion in 'Handguns: Autoloaders' started by Cary, Mar 5, 2007.

Thread Status:
Not open for further replies.
  1. Cary

    Cary Member

    Joined:
    Mar 5, 2007
    Messages:
    2
    Hi – new here but though I would ask for some help. Just picked up a NIB Ruger MK1 (22) and it seems to have a problem. When I’m starting a new clip I release the safety which allows the bolt (probably calling it the wrong name) to come forward. This only loads the shell about ½ way. I have to push on the bolt to finish the loading. It works fine and loads a shell after each shot without problem. Thought it might just be gummy from years of sitting so blasted it with break clean. No improvement. Any thoughts?

    Cary
     
  2. Baphomet

    Baphomet Member

    Joined:
    Sep 6, 2006
    Messages:
    249
    Location:
    Sunny So-Cal
    What you are releasing to drop the bolt on your MKI is not the safety, but the slide-catch, or slide-release, lever.

    Instead of using that lever, grasp the bolt by the ears, pull it slightly to the rear and simply let it drop without any assistance. Yank it back and let it fly. This is referred as the "slingshot" method. Using this technique should solve your problem with the first round not chambering. In fact, using the slide-release for chambering a round is a bad habit to get into, and a less-than-ideal way to chamber a round, in an MK series pistol.

    A thorough scrubbing of the bore and chamber and some proper lubrication would be a real good idea too. You mention using "break clean" but nothing about lube afterwards. You DID lube it, didn't you?
     
  3. Cary

    Cary Member

    Joined:
    Mar 5, 2007
    Messages:
    2
    Thanks!!

    You know - after I posted this I wondered if what you suggested was more appropriate. Yes - I did lube it.

    Thanks for the info and help. I do like the gun.

    Cary
     
  4. wally

    wally Member

    Joined:
    Jan 2, 2004
    Messages:
    12,749
    Location:
    Houston, Tx
    If he really has a MkI there is no slide release lever, the thumb safety does double duty. That's probably why it doesn't feed reliably when released this way since the bolt is not as far back as it would be if held by the MKII lever.

    Put the bolt forward, insert the magazine and them pull the bolt fully rearward and release to load.

    HTH,
    --wally.
     
Thread Status:
Not open for further replies.

Share This Page