Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Running blanks in the M4

Discussion in 'Gunsmithing and Repairs' started by backbencher, Jan 27, 2013.

Thread Status:
Not open for further replies.
  1. backbencher

    backbencher Member

    Joined:
    Dec 13, 2005
    Messages:
    397
    Location:
    Texas
    Any magic way of making Army blanks cycle the M4 bolt, other than screwing the blank adapter down so tight it damages the crown? Running it damp w/ MilTec.
     
  2. rcmodel

    rcmodel Member in memoriam

    Joined:
    Sep 17, 2007
    Messages:
    59,082
    Location:
    Eastern KS
  3. backbencher

    backbencher Member

    Joined:
    Dec 13, 2005
    Messages:
    397
    Location:
    Texas
    Yep, yep, it's yellow. Hammer, bbl work fine, just no gas powered ejection/cocking/reloading cycle. Shot M855 just fine @ the range. Screw it down w/ the Leatherman & risk damaging the crown, or accept training w/ a straight-pull bolt action?
     
  4. paintballdude902

    paintballdude902 Member

    Joined:
    Jun 30, 2007
    Messages:
    2,872
    make sure your gun is spotless and oiled well. ive had trouble with this at work too, PITA.
     
  5. backbencher

    backbencher Member

    Joined:
    Dec 13, 2005
    Messages:
    397
    Location:
    Texas
    Tightening the screw against the crown w/ a Leatherman & adding more MilTec did the trick until a failure to feed - standard for blanks.
     
  6. paintballdude902

    paintballdude902 Member

    Joined:
    Jun 30, 2007
    Messages:
    2,872
    glad to hear it. i ran 5 mags of it tonight and sat down and cleaned it then coated it in mpro7
     
Thread Status:
Not open for further replies.

Share This Page