Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tikka T3 scopemount screwhole issue? anyone?

Discussion in 'Gunsmithing and Repairs' started by xmanpike, Jan 27, 2012.

Thread Status:
Not open for further replies.
  1. xmanpike

    xmanpike Member

    Joined:
    Feb 25, 2009
    Messages:
    447
    Location:
    Houston, TX
    So I just got a Tikka t3 Hunter in 243. I ordered a DNZ game reaper mount for my new scope as I'm not thrilled with the rings that come with it.

    Upon getting it, I removed the plastic plug screws in the top of the action and attempted to install the mount, but the screws did not seem to want to start. Contacted DNZ about the problem, they told me that sometimes the screwholes in Tikka actions can be difficult to start. I found this as a problem with at least one other person thru an internet search.

    I am currently out of town and was when I found this out, but will attempt to resolve when I get home. Just curious if anyone else has had this problem and how the troubleshot it. Recommendations appreciated. I worry about forcing a screw to start and permanently damaging the screwholes.

    Thanks

    MC
     
  2. rcmodel

    rcmodel Member in memoriam

    Joined:
    Sep 17, 2007
    Messages:
    59,082
    Location:
    Eastern KS
    If I didn't have a thread tap to chase the threads, I might grind a slight taper on the end of the screw with a fine belt sander belt and use that.

    rc
     
  3. 7.62X?

    7.62X? Member

    Joined:
    Dec 10, 2011
    Messages:
    18
    Location:
    MN
    buy a tap or bring it in some were
     
  4. xmanpike

    xmanpike Member

    Joined:
    Feb 25, 2009
    Messages:
    447
    Location:
    Houston, TX
    Thanks guys. I like your idea RC of tapering the screw.
     
  5. 7.62X?

    7.62X? Member

    Joined:
    Dec 10, 2011
    Messages:
    18
    Location:
    MN
    remember them threads are metric.
     
  6. xmanpike

    xmanpike Member

    Joined:
    Feb 25, 2009
    Messages:
    447
    Location:
    Houston, TX
    I was told the threads were metric only on the 2003 and earlier models Tikka's. Is this not correct?
     
  7. 7.62X?

    7.62X? Member

    Joined:
    Dec 10, 2011
    Messages:
    18
    Location:
    MN
    was is made in the USA? Then it is MM
     
  8. drsfmd

    drsfmd Member

    Joined:
    Mar 6, 2009
    Messages:
    828
    STOP! Did you try to thread the screws into the holes without the mount? It's more likely that the holes on your mount are slightly off than it is that Tikka sent the wrong screws. Don't tap or chase anything until you try this...

    EDIT: Did DNZ supply the screws? Do what I suggested above. If that doesn't work, go to your LGS and buy a set of screws-- they shouldn't cost you more than a dollar or two. I'd bet money that the problem isn't on Tikka's end, no matter what DNZ tells you...
     
    Last edited: Feb 3, 2012
  9. Horsemany

    Horsemany Member

    Joined:
    Jan 6, 2007
    Messages:
    1,320
    Location:
    Midwest
    There was a point where Tikka changed their screws from metric to american. I don't recall when it was but 2003 sounds feasible. You're not the first one to have this problem.
     
  10. TonyM

    TonyM Member

    Joined:
    Oct 9, 2010
    Messages:
    90
    Location:
    Groton, CT
    Please post what you finally figured out- I'm considering a Tikka and since I posess the "anything that can go wrong, will" type of luck, I'd like to know! :)
     
  11. Zeke/PA

    Zeke/PA Member

    Joined:
    Feb 24, 2005
    Messages:
    2,295
    Location:
    Southeastern Pa.
    I installed a mount on a Tikka for a friend this past fall and had some trouble with the screws/holes.
    One particular screw "screwed" easier than the rest so I used this screw as a cleanout/tap you might say.
    Then I was home free.
    I'm thinking thay MAYBE the screw hole plugs left a residue in the holes.
     
  12. Kstadt

    Kstadt Member

    Joined:
    Feb 15, 2012
    Messages:
    1
    Tikka T3 Lite screw hole problem

    I purchased the DNZ Game Reaper Tikka T3-High Mount (Black) for my 308 attempting to mount a Nikon 4X12X50 scope. When going to mount, the screws that came with the DNZ product seemed not to fit, and I did not want to force it and possibly mess up the threads. I am about to return this mounting / ring system and would like feedback from anyone that has used this mounting system on their Tikka T3.
     
  13. xmanpike

    xmanpike Member

    Joined:
    Feb 25, 2009
    Messages:
    447
    Location:
    Houston, TX
    So, long story short. Apparently the screw holes were just not tapped well to begin with. I got them started, and even though it didnt feel right, they looked staright and I proceed to turn them in with an allan wrench. I did this without the mount to start, once they were in far enough I back them out, put a small drop of 242 loctite on them and proceeded to lock the mount down. Seemed to work just fine. Took the gun out, boresighted by eye, first shot 3.5" low, .5" left at 100 yds. Adjusted new burris 4.5-14x scope. 2nd shot dead bull. Shot 8 more handloaded rounds all with an inch of bull, and they were two different loads (although just slightly). Very pleased with the gun. Mount seems great other than screwhole issue, which I think was Tikka's issue not tappping them great to start.
     
Thread Status:
Not open for further replies.

Share This Page