1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTE with well used Pro CDPII

Discussion in 'Handguns: Autoloaders' started by mach1.3, Sep 11, 2010.

  1. mach1.3

    mach1.3 New Member

    Jul 7, 2010
    I have a Pro CDP II .45 with probably 2000+ rds on the odometer. Recently, at the range it has jammed on the 2nd. to 3rd. round. The shell seems to get canted nose downward enough in the magazine that the slide doesn't feed it into battery. The slide goes into battery but w/o chambering a rd. I did make the mistake of firing some Remington UMC 230gr RN ammo---and that is dirty burning ammo! I noticed powder residue within the outer 11/2" of the guns slide and muzzle plus the the feedramp looked sooty. My question is 1) is this only the result of a dirty gun---feedramp? 2)Is my magazine spring too weak or the follower tilting? As in I need to buy a couple new Wilson Combat mags?? 3)or another problem I haven't considered.

    This problem occurred with both my magazines--OEM Kimbers--but both are relatively the same age.

    I guess I'll give the gun a good cleaning--as well as the mags and head over to the range with different ammo. Could there be another likely culprit I'm not aware of that's causing my problem?

    Any suggestions will be appreciated. I hate having to troubleshoot these kind of problems. I especially hate to spend much money and find out later it was something simple.
  2. 9mmepiphany

    9mmepiphany Moderator

    Dec 27, 2002
    northern california
    It sounds more like a mag problem than anything else. I can't remember who makes the mags that come with a Kimber, but I'd highly recommend McCormick PowerMags or Metalform

Share This Page