1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Glenfield Marlin Model 60

Discussion in 'Rifle Country' started by workingman, Dec 28, 2011.

  1. workingman

    workingman New Member

    Nov 7, 2011
    Howdy folks,
    I have a Glenfield model 60. It about 28-30 yrs old. Was given to me as a Christmas gift about 1981. It has been a great little gun. Still is. It just jams a lot. It still shoots cci mini mags however. Yesterday I shot 100 rds. No jams. As quickly as I started with the bulk stuff, jam jam jam. Federal bulk match was the worst. Every other shot it would jam. I think the ammo was just to weak to completely cycle the action. It would eject the spent shell (most of the time) but would not bring up the next one. Simple solution I know is to just use the mini mags. But I figure it is just a matter of time before they to become a problem. I did strip it down and clean it. Not clean enough. I may try it again. What else should I look for?
  2. 1madss

    1madss New Member

    Aug 10, 2011
  3. TwoWheelFiend

    TwoWheelFiend Member

    May 15, 2011
    I would give it a thorough thorough cleaning. .22's are dirty little things
  4. TwoEyedJack

    TwoEyedJack Member

    Dec 22, 2011
    Southwest Idaho
    I have a model 60 my dad gave me in 1969. I shot about 15,000 rounds through it and wore out the feed ramp and shot the barrel lose. I took it to a gunsmith and he replaced the feed ramp, re-peened the barrel, and it shoots like a champ again. If the jamming you are experiencing is a new development, it could be that your feed ramp is worn out. Also, make sure it is super clean and use a very light lube like rem oil. If it really cold out, consider running it with no lube.
  5. Furncliff

    Furncliff Senior Member

    Dec 10, 2005
    Western Slope of Colorado
    I had feed ramp problems with mine as well. Part is cheap , the replacement is pretty easy.
  6. WNTFW

    WNTFW Participating Member

    Jul 16, 2006
    Make sure the extractor are working freely in the slots of the bolt.
    Tune ejector if needed.
    Clean the action.
    Make the long spring that pushes bolt forward in working correctly and not kinked or binding.
    Check feed ramp and also make sure mag tube plunger is working 100%
  7. Elkins45

    Elkins45 Senior Member

    Dec 25, 2009
    Northern KY
    Sometimes the problem is a cracked recoil buffer. That's the white nylon thingie behind the bolt. If it's cracked it absorbs too much of the recoil impulse and it doesn't have enough oomph to cycle. That might be why the cheap stuff doesn't work and the better stuff does-it has the little extra energy needed to overcome the loss of energy.

    It's an easy fix if that's what is wrong.
  8. stevekozak

    stevekozak New Member

    Jul 1, 2011
    This would be my guess. I have a 60 I bought back when I was a young feller, and the only problem I have ever had with it was when that recoil buffer cracked on it in the first year. I called Marlin and they sent me two new ones (one for a spare) for free. These were black. I don't know if they were better material or what, but 1000;s and 1000s of rounds later, it is still going strong with no cracking of the buffer. I still have the spare new and waiting!!
  9. Buckyt

    Buckyt New Member

    Dec 22, 2011
    I had a model 60 that I bought in 1964 and when it would jam, I found that a good cleaning would fix the problem. About 18 years ago somebody broke into my cabin and solved that problem by stealing my old Marlin. I have intended to replace that gun because it was such a good shooter, but just haven't yet.
  10. jwsracin

    jwsracin New Member

    May 9, 2010
    check the buffer block first, most common problem. then check the feed ramp, my 79' 60 will only feed slick headed copper coated bullets everytime.
  11. joesmithmtp

    joesmithmtp New Member

    May 8, 2012
    I have a 14 year old Marlin Model 60 that has had less than 50 rounds through it. I'm planning on shooting the CCI Velocitor through it at coyotes - 150 yrds max. I have been told to expect the buffer to break in that the rifle isn't made for the hot Velocitor - 40grs, 1435 listed muzzle speed. Question: How do you change the buffer? Is there other damage that could occur? Is there an after-market buffer that is stronger/more durable than original equipment? I see good things written about using the Velocitor against coyote, and others, who have not used it, saying that it is a bad idea; do you have any thoughts about the Velocitor? God bless.

Share This Page