1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Taurus 85 problem

Discussion in 'Handguns: Revolvers' started by the naked prophet, Dec 27, 2006.

  1. the naked prophet

    the naked prophet Well-Known Member

    I went out to practice with my snub revolver, a Taurus 85 stainless (DAO, concealed hammer) and I encountered a problem.

    No matter what ammo I was using, every few shots the cylinder will bind. The trigger just locks up, and the cylinder won't turn.

    It's not the same cylinder each time.

    If I let loose of the trigger, and pull it again, the bind is gone.

    The same thing happens with all ammo: wal-mart 125 grain FMJ, CCI blazer 148 grain light wadcutters, Remington +P SJHP, standard pressure 158 grain cast SWC reloads, and my carry ammo Speer Gold dot 135 grain short barrel +P.

    The primers aren't backing out, The bullets aren't coming loose from the cases. The brass is extracting easily.

    This happens even before there's significant carbon buildup on the front of the cylinder. It happens after one shot, or after 100. But never on the first shot.

    It doesn't feel like a constant drag, just like there's something getting caught. It's smooth the rest of the time. It doesn't happen when using snap caps, either. There is no burr on any of the "gears" on the extractor, or on the hand.

    I'm just wondering what it could be. I've never had it apart, myself. So what could be the problem? This is my normal BUG and occasional (dress clothes) primary.
  2. mnrivrat

    mnrivrat Well-Known Member

    It sounds like the top of the transfer bar is perhaps getting caught on the bottom side of the firing pin rather than running over the top of it like it should.

    There could be other reasons as well, but that is the first thing I would look at. Since it is an internal problem you should either be familiar with the mechanizim to work on it yourself, or just send it back to Taurus for repair with a clear statement as to what is happening. Their turn around time is about 3 weeks on warrenty work.
  3. 1 old 0311

    1 old 0311 member

    It DOESN'T happen with snap caps? I would pull the side plate off and clean with compressed air, or brake clean. You may have a bit of unburned powder that is getting into the action.
  4. bakert

    bakert Well-Known Member

    Check for powder granules or dirt under the star extractor of the cylinder.
  5. raghorn

    raghorn Well-Known Member

    I had a similar cylinder lockup problem with a brand new 85CH that I bought in the early 1990s. I sent it back to Taurus and they fixed it for me and returned it within a month. The problem didn't recur after that but by then I'd "lost that lovin' feelin'" for it and sold it to buy a S&W.
  6. Jkwas

    Jkwas Well-Known Member

    My taurus 605 would do the same thing. But only when other people used it, like my wife. The problem for me was short-stroking the trigger. If you don't pull the trigger all the way back, and then don't let it reset all the way forward, then pull back again, the gun will lock up. If you pull the trigger slowly, and let the hammer fall without pulling the trigger all the way back, the transfer bar falls and the gun does not fire. Make sure you're not doing this first. Also I've had some cheap ammo that was so dirty it required wiping off the front of the cylinder and forcing cone to stop binding. Try some CLP down the hammer opening and check your technique before sending it back.
  7. MCgunner

    MCgunner Well-Known Member

    Does it do this without ammo just dry firing? If it don't, it could be high primers on the ammo. Not likely, but it could happen with a batch of factory stuff. I used a Lee hand priming tool years ago and the pin the lever pivots on slowly bent. One day I'm out at the range with my trusty Model 10 and this starts happening. It took me a little to trace down why. That's when I got an auto prime 2, press mounted primer, and never had the problem since. I load mostly on progressives anymore.
  8. the naked prophet

    the naked prophet Well-Known Member

    The primers are not high, and are not backing out. There is no dirt anywhere on this revolver, period. I scrub it to new shining condition each time I shoot it, and it stays practically lint-free in the "smart carry."

    I can pull the trigger halfway, let go, pull the trigger, and it'll fire (with snap caps). I can pull the trigger any combination of partway and then all the way, and it'll fire. If it does otherwise, I think there's a problem with your revolver. Releasing the trigger and pulling again is the only way to "fix" the bind when it happens.


    I just took off the side plate. I see how everything works now. Still not gonna take it apart.

    There's not a speck of dirt in the whole thing. I had my gunsmith clean it real well and grease it when he replaced the extra-heavy hammer and trigger reset springs with lighter Wolff springs (yes, thoroughly tested with carry ammo to ensure 100% ignition). Still looks pristine with clean grease.

    The ONLY thing I could see that might cause the problem is when the transfer bar raises, sometimes it doesn't move rearwards to get behind the firing pin, and instead slides up the ramped surface of the back of the firing pin. I pushed the transfer bar forward, against the frame, as I pulled the trigger and the transfer bar got stuck against the bottom of the firing pin. The trigger felt exactly the same as when I was shooting and the trigger got stuck. Now I just have to figure what was causing the transfer bar to go forward (or, rather, not go back) and jam against the bottom edge of the firing pin in the first place.

  9. Jkwas

    Jkwas Well-Known Member

    I read your post, then I went to the "reading room" with my taurus and contemplated what you said. The transfer bar "floats". When I point the gun straight down at the floor and cock the hammer I can see the bar slide up and over the firing pin. How does the firing pin look? Is there a burr or something on the underside? Same for the bar. Is it possible some debris has gathered behind the firing pin in the frame that's forcing the pin back further than it should go, and in turn presenting a flat spot for the transfer bar to catch on? Looking at the taurus illustrations on their website, I can't see any mechanism that "forces" the bar rearward, it just seems to have free travel fore and aft.
    Dumb question: Have you tried engaging and disengaging the lock?
    Maybe I didn't explain the short stroke thing. I can get mine to bind up at will.
    Pull the trigger all the way back and let the hammer drop (unloaded of course)
    Let the trigger go forward til just before the last "click"
    Now try and pull it back
    You can't do it.
    If I do the same thing with my S&W, it doesn't bind, but it won't "pick up" the cylinder and turn it either.
  10. the naked prophet

    the naked prophet Well-Known Member

    Fairly smooth. No burrs anyway, not polished smooth though.

    No debris. Clean as a (greased) whistle.

    That would explain why I couldn't see what it was that pushed it rearwards :eek:

    Lock? What lock? I should have mentioned that this is a pre-lock Taurus.

    Okay, I just tried that. Mine locks up too, but that's definitely not what was happening before. The trigger would get almost to the end of the stroke (where the hammer was fully cocked) and then get stuck.

    I may do a bit of very fine sanding and polishing on the transfer bar and firing pin backside, and see if that fixes it. Or, more likely, have my gunsmith do it.
  11. Jkwas

    Jkwas Well-Known Member

    Sounds like a plan. Is it very "high mileage"? Maybe have both replaced for peace of mind.

Share This Page