Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Should I Sell My TA60 Mount for my ACOG?

Discussion in 'Rifle Country' started by 4Freedom, Mar 3, 2009.

Thread Status:
Not open for further replies.
  1. 4Freedom

    4Freedom member

    Joined:
    Nov 29, 2008
    Messages:
    674
    Hi, I just bought a new LaRue LT105 mount and have mounted it onto my ACOG TA33R-8. Now I have an unused TA-60 Mount that came with my ACOG which I seem to have no use for. I don't have any other optics that I plan to mount with it. I am really a bit in need of money. I see these retail for around $100.00, as much as my LaRue mounts retail for. Can anyone give me any good reason why I should hold onto my TA-60 mount? Or, do most of you think the LaRue mount will do the job in all scenarios for my ACOG and I should sell the TA-60 mount which will just sit in my closet and collect dust?

    I am thinking I will probably sell it for $87.00 and free shipping for anyone wh wants it. Its brand new and never used. I hear the wait time to get one of the mounts from Trijicon is a month or more. However, I am not sure if it would be good to hold onto it for some reason. I was always told the LaRue mount is a better way to go for the little bit extra money, but not sure. I know the TA-60 mount looks like it would hold on better than any other, seeing you can screw it on.
     
  2. Dienekes

    Dienekes Member

    Joined:
    Dec 26, 2002
    Messages:
    1,905
    Location:
    Wyoming
    Well, I have one sitting unused as well (off a TA33 also). I just haven't gotten around to posting it.

    If you like the La Rue I don't think you're likely to need it in the future. My setup is different but works fine.
     
  3. husker

    husker Member

    Joined:
    Dec 28, 2008
    Messages:
    1,475
    did you drop off your prob at a smith today? ill send ya some pics of my acog
     
  4. 4Freedom

    4Freedom member

    Joined:
    Nov 29, 2008
    Messages:
    674
    YEP.. PROBLEM SOLVED.. It turned out that I used a metric allen wrench instead of the US measurement allen wrench. I totally messed up because of my own stupidity. The gunsmith was a great guy, promising not to tell anybody how dumb I was by using the wrong wrench. Really, I just coudln't belive it, it fit like a glove and I just thought it was the right one. It turns out the 1/8 in allen wrench is almost the same size as the metric one I had, but the little difference in stripping the screw. However, the screw was not stripped bad enough for the allen wrench to unscrew it. I got my LaRue mount on my ACOG now safe and sound. :D

    Thanks for yours and Zaks help BTW.
     
Thread Status:
Not open for further replies.

Share This Page