Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need some 1911 Help

Discussion in 'Handguns: Autoloaders' started by mkonops, Jul 16, 2007.

Thread Status:
Not open for further replies.
  1. mkonops

    mkonops Member

    Joined:
    Mar 12, 2007
    Messages:
    130
    Location:
    CT
    Hey guys, hoping to get a few suggestions here. I have a 1911 that i just replaced all the springs in, and I took it out for a test round yesterday. It was shooting fine at first, though the spent shells were ejecting straight back at my face and head. After about 75 rounds it began to FTE, but it wasn't a "stovepipe" as the spent shells seemed to be stuck sideways in the ejection port. Does anyone have any suggestions? Do I need a weaker or stronger spring?

    Here is a link to the spring set I used:
    Wilson Combat Complete Spring Set 1911 Government

    Here is its description:
    "A set of all the springs necessary to construct, rebuild or recondition your 1911. These springs are built from high tensile spring steel, assuring a consistently smooth action, positive ignition and proper timing. Set includes: Sear spring, 18-1/2 lb heavy-duty recoil spring, extra-power firing pin return spring, plunger spring, magazine release spring and mainspring."

    The only spring I did not replace was the mainspring.
     
  2. 45auto

    45auto Member

    Joined:
    Dec 30, 2002
    Messages:
    1,241
    I'd ask first if the gun worked fine before, i.e didn't hit you in the face or stovepipe, with the same ammo and what # recoil spring you had before?
     
  3. mkonops

    mkonops Member

    Joined:
    Mar 12, 2007
    Messages:
    130
    Location:
    CT
    I bought the gun used and it wasn't functioning well from the get go. It had a problem with the grip safety spring so it was a battle just to get it to fire. I figured since it was so old, all the springs could stand to be replaced, so thats what I did. Now it fires every time and the slide locks back like it should after the magazine is empty, but I have the ejection problem. I do not know what weight the old spring was, and of course I probably threw it out, though I will check when I get home.
     
  4. JDGray

    JDGray Member

    Joined:
    Sep 16, 2005
    Messages:
    5,131
    Location:
    SW MI.
    The heaver recoil spring may be the cause, slower going back and faster going forward. Swap back to the one you took out, and see:)

    16# is factory on a 5" gun
     
  5. mkonops

    mkonops Member

    Joined:
    Mar 12, 2007
    Messages:
    130
    Location:
    CT
    Thanks, the one I got is an 18.5# - that must be the problem. I'll try a 16 and see what happens. I guess I shouldn't have bought the "heavy duty" version. That must be for hot loads or something.
     
Thread Status:
Not open for further replies.

Share This Page