1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Talley rings

Discussion in 'Gunsmithing and Repairs' started by amflyer, Oct 28, 2013.

Thread Status:
Not open for further replies.
  1. amflyer

    amflyer Member

    Aug 5, 2008
    Bit of a strange problem when mounting a scope on a rifle last night.

    I've always used Leupold rings, but recently have moved to Talley detachables for the last two rifles. I de-greased the rings and screws, and assembled them on a new Zeiss Conquest. I snugged down the bottom two screws, but did not torque them yet, mounted the rings and scope on the bases, and aligned the scope for cant and eye relief. This is according to their instructions.

    When I tried to tighten the top two screws on the rings, I got little resistance and couldn't get the screws to even begin to tighten. I always try to incrementally tighten all four across the two rings, and all of them were like this. At first I thought that I wasn't engaging the treads on the rings.

    I came to the conclusion that something was wrong (not really thinking about stripped threads at this point) and removed the screws. They appeared fine. I tried them in the holes and noted that I could "press-fit" the screw with just a little pressure into the holes in the rings, almost like tightening a zip-tie. Stripped!

    Almost completely sure that I didn't over tighten. I usually snug the screws with a hand-driver, then torque with a FAT wrench, and I never made it to the latter step. No "farmer-tight" for me.

    Called Talley this AM, and of course they shipped me a new set ASAP, but never could really figure out what I was doing wrong. If it were a lesser product I may be more apt to blame it on the steel, but Talley is pretty danged good stuff. Had no troubles with the other set on a 375 H & H.

    Any thoughts or ideas?
Thread Status:
Not open for further replies.

Share This Page