Quantcast
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ARMS quick release scope mount won't hold zero...

Discussion in 'Rifle Country' started by anymanusa, Nov 24, 2008.

Thread Status:
Not open for further replies.
  1. anymanusa

    anymanusa Member

    Joined:
    Aug 8, 2007
    Messages:
    342
    Location:
    Beautiful South
    The company guarantees zero, because they claim the quick release pulls down instead of horizontally, but I can't keep zero on any of my picattiny rails on my rifles. It is a little too loose, and the p.o.i. jumps around a lot.

    Are their shims for sale to help this problem?? What are my options?

    Thanks.
     
  2. Coronach

    Coronach Moderator Emeritus

    Joined:
    Dec 20, 2002
    Messages:
    11,109
    I assume that you know your rails are milspec, right? ARMS is no Larue, but it should be able to hold zero fine.

    If I was certain my rails were correct, I would contact ARMS and request a replacement. Failure to re-zero is a "you get what you pay for" kinda deal, but failure to even hold zero is a serious defect.

    Mike
     
  3. anymanusa

    anymanusa Member

    Joined:
    Aug 8, 2007
    Messages:
    342
    Location:
    Beautiful South
    I have four different rails that the ARMS will not hold zero on, one of which is a bushy flattop, another bushy spacers. The other two are just cheapo rails. I assume the bushy stuff is milspec, but that is only an assumption.
     
  4. ugaarguy

    ugaarguy Moderator Staff Member

    Joined:
    Mar 19, 2006
    Messages:
    12,013
    According to the folks over on AR15.com failure to maintain zero is actually pretty common with ARMS mounts.
     
Thread Status:
Not open for further replies.

Share This Page